CSV Import element mapping problem

I am running Omeka 2.0.3 and CSV Import 2.0. When I attempt to map the columns from my csv spreadsheet to Dublin Core elements, I am not getting a complete list of elements - Identifier, Creator and Title do not appear on the dropdown menu. I tried selecting different item types (document and still image) but encountered the same problem. If I try to bypass, the item type the elements appear but I am unable to complete the csv upload following this process. Suggestions? Thanks.

So, when you pick an item type, any item type, not all the elements appear, but all the elements do appear if you don't pick an item type?

What other plugins are you using? (System Information off the lower-right corner of the admin panel is an easy place to get all your plugins and their versions)

Regardless, one initial thing I'd try is updating to the latest CSV Import version. CsvImport 2.0.2 still supports Omeka 2.0.3.

We are using these plugins:
That is correct. Here is the list of plugins and versions that I am running.
Coins 2.0.1
Commenting 2.0
CsvImport 2.0
Dropbox 0.7.1
DublinCoreExtended 2.0.1
ExhibitBuilder 2.0.3
SimplePages 2.0.1
I will try updating to the most recent version CSV version.
We are running two instances of Omeka and the version which is using an earlier version of csv import (1.3.3) doesn't have this problem.

Hello Again. We updated to the most recent CSV Import plugin (2.0.2) as you suggested but the problem persists. I still do not see the identifier, creator or title fields when I pick document. moving image or still image as the item type. They do appear on the list when I don't select the type but I get an error message when attempting to upload the data this way. These fields do appear when I add a single item. Any other recommendations?

I can't confirm this problem, whether or not Dublin Core Extended is installed.

Is it possible that you have assigned those fields (Identifier, Creator, and Title) to some specific Item Type? You're not intended to be able to do that, since the Dublin Core fields are already available for all items.

But, I seem to remember a bug in some older version of Omeka that for a short time did allow you to add an element like Title to an Item Type. Looking at the code that filters the dropdown list by Item Type in CSV Import, it would cause a problem like you're seeing if Identifier, Creator, and Title were assigned to an Item Type.

We haven't made any modifications to the item type. Could I add the missing fields to the item type? Could I have the same field in multiple item types? Is there any way to do a batch import without selecting the item type?

You haven't edited the Item Types at all?

You don't need to add any of those elements to any of the item types, they're available for all Items, no matter what type they have. I was just speculating about something that could possibly explain why those elements, and only those, are gone when you choose an item type in the CSV plugin. You're sure you haven't touched any of the item types? (it wouldn't have to be the same ones that you're trying to use in the importer)

Also, yes, you can do a CSV Import without choosing a type. You said you got an error when you tried to do that. What was the error?

No. I have looked at the item types but not made any modifications. My colleague followed the instruction in the codex for getting error messages to show but that didn't work. Should we go with the error log instead?

Here is the message from the error log:
2014-06-09T08:41:14-04:00 ERR (3): exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli prepare error: Unknown column 'original_filename' in 'field list'' in /var/www/application/libraries/Zend/Db/Statement/Mysqli.php:77
Stack trace:
#0 /var/www/application/libraries/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `om...')
#1 /var/www/application/libraries/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `om...')
#2 /var/www/application/libraries/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `om...')
#3 [internal function]: Zend_Db_Adapter_Abstract->query('INSERT INTO `om...', Array)
#4 /var/www/application/libraries/Omeka/Db.php(79): call_user_func_array(Array, Array)
#5 /var/www/application/libraries/Omeka/Db.php(252): Omeka_Db->__call('query', Array)
#6 /var/www/application/libraries/Omeka/Db.php(252): Omeka_Db->query('INSERT INTO `om...', Array)
#7 /var/www/application/libraries/Omeka/Record/AbstractRecord.php(543): Omeka_Db->insert('CsvImport_Impor...', Array)
#8 /var/www/plugins/CsvImport/models/CsvImport/Import.php(460): Omeka_Record_AbstractRecord->save()
#9 /var/www/plugins/CsvImport/controllers/IndexController.php(134): CsvImport_Import->queue()
#10 /var/www/application/libraries/Zend/Controller/Action.php(516): CsvImport_IndexController->mapColumnsAction()
#11 /var/www/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('mapColumnsActio...')
#12 /var/www/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#13 /var/www/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#14 /var/www/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#15 /var/www/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#16 /var/www/admin/index.php(28): Omeka_Application->run()
#17 {main}
FYI - The spreadsheet that I am importing does not include a column with the heading 'original_filename'

Try uninstalling and reinstalling CSV Import (though the Uninstall and then Install buttons on the Plugins panel).

This looks like the table CSV Import is using just isn't set up right.

That worked. Thanks so much.