Changing URL after initial install

I'm a very new user, so this might be a basic question.
I installed Omeka using the helpful installation codex. It finally worked, after a couple tries. The only problem is that now my Omeka site isn't located at the basic URL of my site ( but rather at the URL, because I named the Omeka directory "project," as recommended in the Codex, and put it in the domain's html folder.
How do I change this?
Thanks in advance -

It should work to try installing it again, but, since it sounds like there aren't other projects (e.g., WordPress installations) on your server, put it directly into the domain's html folder

Hi Patrick! thanks for replying.

You're right - there are no other projects on the server. I put it directly into the HTML folder this time, as well (it's currently located in domains->>html->project).

I think what's tripping me up is the naming. The codex told me to name it "project" (or anything else of my choosing) and then visit to install. If I rename it, how can I avoid naming it something that will also append to the URL, in the same way "project" did?

I hope this makes sense. Thanks again for helping.


Oops, I meant "there are no other projects on the domain" - there *are* others on the server. I have three domains, and the other two have WP installed.

Don't know if that makes a difference.

The codex instructions assume you might want to have multiple different top-level folders in a domain.

You can place the Omeka files directly in your domain's "html" folder, and that will avoid any "extra" stuff after the URL. You can do this by simply moving everything from the Omeka folder up one level to be directly in the "html" folder, but you have to make sure to get everything, including all the folders and the .htaccess file.

Thanks.That makes sense (when I look at my other domains, I can see how WordPress exists in their HTML folder that way).

I reinstalled the same Omeka materials as before, this new way, and now I get an error message when I go to the URL and try to install. Seems strange, since when I installed at the other URL, I didn't get this. Any ideas? I'm copy and pasting:

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /nfs/c07/h02/mnt/101667/domains/ on line 21

Thanks so much, again.

Did Omeka work correctly when you had it in the "project" subdirectory?

Usually this error would be caused by trying to run Omeka with PHP 4. Omeka requires PHP 5.2.4 or greater (PHP 5.3 is recommended).

When I had it in the "project" subdirectory, I was able to install it without encountering this warning. Weird.

However, I just figured out how to upgrade my PHP, and it worked! I just installed it on the main URL. Check it out: I'm in business.

Thank you so much!