Preparing to Install

Before installing Omeka, make sure your web server meets our basic system requirements. These are standard requirements that are available by most web hosting services. Once these system requirements are met, all you need to do is install the Omeka software:

System Requirements

  • Linux operating system
  • Apache HTTP server (with mod_rewrite enabled)
  • MySQL version 5.0 or greater
  • PHP scripting language version 5.2.11 or greater (with mysqli and exif extensions installed)
  • ImageMagick image manipulation software (for resizing images)

What if I Do Not Have Access to LAMP?

Preparing Your System

Instructions for preparing different Linux distributions to host your own deployment are included below:

Upgrading Your System

If you need to upgrade your server to meet any of the Omeka system requirements, consult these resources:

Local and Virtual Machines

There are a number of options available for creating a local installation or running a virtual machine if you don't have a LAMP server available. Below are some suggestions. Please contact their support if you have difficulties.