Zotero Import Failure

Hello! I have installed Omeka on the shared server at my university and am trying to import a public library from Zotero. When I try to import, the operation times out, and I'm redirected to a generic page that states:

"The web server is unable to deliver the page you requested."

I've tried contacting my university webmaster, but wasn't able to receive much help because they don't provide support for Omeka.

I think this may be an issue with the server's configurations, but I have no idea exactly what might be causing the import to fail. I'd be happy to provide more information, and any suggestions would be greatly appreciated!

Thanks in advance!


Errors such as this tend to be intermittent, so I'd continue to try. In the meantime, I'll need some information:

* Omeka version
* Zotero Import version
* Zotero Atom Feed URL

Thanks for your reply. I installed Omeka and the Zotero plugin last Friday and have been getting the same error since then.

Omeka version: 1.4.2 (also tried installing 1.3, but got the same error)

Zotero Import version: 1.2

Zotero Atom Feed URL: https://api.zotero.org/users/883532/items

I successfully imported 28 items from your library, so I can't reproduce the error. I imagine you're right that it's an issue with the server configuration.

Is an Omeka collection being created every time you attempt to import your library? Is a new row being added to the Imports table?

You should turn on error and process logging. In application/config/config.ini set log.errors = true and log.processes = true. Make sure application/logs/errors.log and application/logs/processes.log are writable by the web server. After running the import, check if anything was added to these files.

Just got it to work! Based on another post here, I deduced that I needed to specify the PHP path in application/config/config.ini. And that was all it took. Thanks again for your help!

Hi TT!

Please can you be more specific about how you got it to work?

jsafley (Omeka Dev Team) wrote:

It looks like the auto-detected PHP-CLI path is of an incompatible version of PHP. You'll need PHP-CLI 5.2+. If your hosting service offers a compatible version, set its path in omeka/config/config.ini, background.php.path="/path/to/php"


I reset the path as suggested but didn't get it to work...


Hi, Archiblog. Per jsafley, I set the value of background.php.path in the application/config/config.ini file to the PHP installation path on the server I'm using (in my particular case it was installed at "/usr/local/php5.2.14/bin/php"). Have you gotten it to work for you?

Hi TT,
Thanks for responding!
There appears to be only one file in my /user/local/ file - namely, 'remove.txt' - an ASCII Text.
Any thoughts?

To find background.php.path in application/config/config.ini, run the following command in terminal:

$ which php

That will display the path to PHP on your server. It will be something like "/usr/bin/php", but it could be something completely different. You then need to determine if that instance of PHP is version 5.2.4 or above. Do that by running the following command. (Make sure to replace "/path/to/php" with the path displayed after you ran the "which" command.)

$ /path/to/php -v

The first line of output will display the PHP version. Hopefully it is equal to or greater to 5.2.4. If not, try running "which php5" and repeat.

You should now have a valid background.php.path.

Thanks for your detailed instructions jsafley!

Now I don't think they sound too advanced for me, so I might have a go when I'm feeling bold! It would certainly be great to import the Zotero feed from my library.

I'll let you know how it goes...

hi good morning,

I want to apologize because I do not speak English and I hope that I can understand using the Google translator.

My problem is very similar to this post, except that my plugins do work. The difference is that when I try to create a report or import a list of Zotero I get the following message "The PHP configured path (/ usr / bin / php) points to a PHP-CLI binary With A Different version number () than the one Omeka is running on (3.5.10-1ubuntu3.1). ". And the application is telling me that the operation is in progress. But if you refresh the page (F5) processes have been successfully concluded. the problem is I have to calculate the time to imagine that the process is complete. Now try changing the PATH using the instructions php-v "which php". But the message still appears.

I hope my PC can help correct the problem.

Otherwise the software is very good.

Thank you!

vinz3g, does the import work? I don't recognize that error. What Omeka and Zotero Import versions are you using?

hello jsafley
Omeka version is 1.5.1 and the Zotero plugin Version 1.3;
Reports plugin is Version 1.0beta

Thank You!

You mention that your plugins work. Does the Zotero Import plugin successfully import items?

There is no error message in Omeka that matches what you wrote above. Are you sure you have that right? There is an error message that says: "The configured PHP path (...) points to a PHP-CLI binary with an invalid version (...)". If that is the case the import should not have worked.

hello again,

Indeed the plugins work, but have this bug, in which you need to refresh the page so you can see the result, I'm running Omeka on two servers, one with version 11.10 of ubuntu and another in version 12.04 of ubuntu, in both cases the same problem.

That's expected behavior. There's no way Omeka can push status updates to the browser without the user reloading the page.

I send links with pictures of the process before and after using the update page (F5)


one last question

When working with the importer Zotero references, how I can know that the process is over?, Do not interrupt the process if the page charge again?

For example if I try to upload to the server 100 records, how long should be charged?

Thanks for answer and an apology for not being very clear in my questions.


Thanks for the screenshots. I am baffled by the warning message. I can't find it in the Omeka codebase. We'll continue to look into it, but if the processes work, I wouldn't be too worried about the message.

The only way to know if a process is over is by waiting until the status changes from "In Process" to "Error" or "Completed". Feel free to navigate away from the page while the process is running; it will continue to run in the background even if you close the browser.