Zotero Import Error

Zotero Import returns an "error" status.

I have a Zotero 2.1.4 one-click install on dreamhost (http://saiic.nativeweb.org/omeka/) running PHP 5.6 and I have the current version of Zotero Import (2.0.2). The Zotero db that I'm trying to import (https://www.zotero.org/groups/abyayala) does not appear to have a private key. Yet, the import returns an "error" status within milliseconds of starting the import. I cannot find an error log, nor an indication in these forums what might be the problem. Any ideas? Thanks!

Could you post the exact URL that you are using? It should be url to the feed, something like https://api.zotero.org/groups/467093/items/top?start=0&limit=25&format=atom&v=1

The error log is in application/logs/errors.log, which might give more info

Thanks for your reply. Yes, I just tried the exact URL in your post and it provided an almost immediate "error" status. The error log has nothing in it (not even noise--it hasn't been written to).

Can you tell, is there something wrong with my Zotero db that might be causing a problem?


seems unlikely that it's on the Zotero side -- I pulled in the data without problems.

I'd try uninstalling and reinstalling the plugin, and making sure it's on the latest version.

If that doesn't do it, I'd check with the server admin/hosting company about the correct path to PHP CLI. It might be that Omeka can't correctly guess it. It can be explicitly set in application/config/config.ini on the background.php.path line.

In the same file, you could also change the line

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_BackgroundProcess"


jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

That'll risk the import failing after a certain amount of time, but if it partially works it'll be evidence for the background path not being correct.

Thanks, Patrick. We've tried reinstalling the plugin and setting the path to the PHP CLI (if I understand correctly from http://wiki.dreamhost.com/PHP#Using_PHP_from_the_command_line_.28PHP-CLI.29 on dreamhost it is /usr/local/php56/bin/php) and changing the line that you suggested--but same result.

We stripped the tags out of a group & importing that seemed to work. Might there be a bug with the tags?

We changed the "log.errors" to true in config.ini now it generates the following log. I don't know if there is anything here that means anything to you?

Thanks! marc.

2016-02-02T12:22:08-08:00 ERR (3): exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Column 'time' cannot be null' in /home/nwportal/hosted/saiic/omeka/application/libraries/Zend/Db/Statement/Mysqli.php:214
Stack trace:
#0 /home/nwportal/hosted/saiic/omeka/application/libraries/Zend/Db/Statement.php(303): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/nwportal/hosted/saiic/omeka/application/libraries/Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array)
#2 [internal function]: Zend_Db_Adapter_Abstract->query('INSERT INTO `om...', Array)
#3 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Db.php(79): call_user_func_array(Array, Array)
#4 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Db.php(252): Omeka_Db->__call('query', Array)
#5 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Db.php(252): Omeka_Db->query('INSERT INTO `om...', Array)
#6 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Record/AbstractRecord.php(543): Omeka_Db->insert('RecordsTags', Array)
#7 /home/nwportal/hosted/saiic/omeka/application/models/Mixin/Tag.php(53): Omeka
#8 [internal function]: Mixin_Tag->afterSave(Array)#9 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Record/AbstractRecord.php(251): call_user_func_array(Array, Array)
#10 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Record/AbstractRecord.php(280): Omeka_Record_AbstractRecord->delegateToMixins('afterSave', Array, true)
#11 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Record/AbstractRecord.php(550): Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#12 /home/nwportal/hosted/saiic/omeka/application/libraries/Omeka/Record/Builder/AbstractBuilder.php(67): Omeka_Record_AbstractRecord->save()
#13 /home/nwportal/hosted/saiic/omeka/application/libraries/globals.php(531): Omeka_Record_Builder_AbstractBuilder->build()
#14 /home/nwportal/hosted/saiic/omeka/plugins/ZoteroImport/models/ZoteroImport/ImportProcess.php(176): insert_item(Array, Array, Array)
#15 /home/nwportal/hosted/saiic/omeka/plugins/ZoteroImport/models/ZoteroImport/ImportProcess.php(65): ZoteroImport_ImportProcess->_import()
#16 /home/nwportal/hosted/saiic/omeka/application/scripts/background.php(61): ZoteroImport_ImportProcess->run(Array)
#17 {main}

Hi Patrick, we figured out the problem--Dreamhost installed an old version of Omeka. When we upgraded to the current version the Zotero import now works. Thanks! marc.