Zend_Session_Exception error on Admin login


I have had a misshap during upgrade to 2.4 this morning. I attempted an upgrade via Softaculous but received error messages so I restored the back-up taken before running the upgrade. I now get the Zend_Session Exception pasted further down whenI try to login to the admin control panel. The site itself works OK, it is just the admin.

I have tried having my full site restored from back-ups taken this morning and on Wednesday morning but I'm still receiving the error, so have gone back to this morning's backup.

Can anyone help me to figure out how to recover my Omeka site so that I can login to the backend again please?

`exception 'Zend_Session_Exception' with message 'The session has already been started. The session id must be set first.' in /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Session.php:667
Stack trace:
#0 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Session.php(426): Zend_Session::setId('f67a030e403517c...')
#1 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Session/Namespace.php(143): Zend_Session::start(true)
#2 /xxxx/xxxxxx/public_html/archives/application/libraries/Omeka/Controller/Plugin/Admin.php(74): Zend_Session_Namespace->__construct()
#3 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Controller/Plugin/Broker.php(309): Omeka_Controller_Plugin_Admin->preDispatch(Object(Zend_Controller_Request_Http))
#4 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Controller/Front.php(941): Zend_Controller_Plugin_Broker->preDispatch(Object(Zend_Controller_Request_Http))
#5 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch()
#6 /xxxx/xxxxxx/public_html/archives/application/libraries/Zend/Application.php(382): Zend_Application_Bootstrap_Bootstrap->run()
#7 /xxxx/xxxxxx/public_html/archives/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#8 /xxxx/xxxxxx/public_html/archives/admin/index.php(28): Omeka_Application->run()
#9 {main}


Do you have the PHP session.auto_start setting enabled in php.ini? It should be disabled. This error should only occur if you have that setting on or if you've got some code of your own that's handling PHP sessions itself.

Thanks for your reply John,

Yes, I found that in another one of the threads and I tried it but it made no difference. However, after starting this thread I tried clearing my browser's cache and cookies and then everything started working OK again.

I'll be trying a manual upgrade next!