I am installing omeka and have uploaded the files. When I go to the install directory it throws an error on line 242 of /home/pateam/public_html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php:242 Stack trace: #0...

the code suggests that I
* By default, if a controller is not dispatchable, dispatch() will throw
* an exception. If you wish to use the default controller instead, set the
* param 'useDefaultControllerAlways' via {@link setParam()}.

How do I set this parameter? Hopefully that will fix the problem.

Could you post the full error message that you get, including the exception name and message? I know you've posted the exception in this topic title, but the "message" part should have more useful detail.

You shouldn't have to do any more configuration or set any parameters to get the installer to work.

Here it is:

Fatal error: Uncaught exception 'Zend_Controller_Dispatcher_Exception' with message 'Invalid controller specified (omeka)' in /home/pateam/public_html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php:242 Stack trace: #0 /home/pateam/public_html/omeka/application/libraries/Zend/Controller/Front.php(946): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #1 /home/pateam/public_html/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(77): Zend_Controller_Front->dispatch() #2 /home/pateam/public_html/omeka/application/libraries/Zend/Application.php(358): Zend_Application_Bootstrap_Bootstrap->run() #3 /home/pateam/public_html/omeka/install/index.php(33): Zend_Application->run() #4 {main} thrown in /home/pateam/public_html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php on line 242

You can see for yourself at:

Thanks for getting back to me on this.

Have you edited the .htaccess file in the install directory at all, in particular the RewriteBase line?

Your setup shouldn't need the RewriteBase setting, but you could try setting it as /omeka/install/.


I tried that just now. No joy. I think you are on to something though so I should explain that I am trying to install Omeka in a subdirectory under public_html because I have Wordpress installed in the folder just above it. I am trying to emulate the combination that Erin Bell has running. http://omeka.org/forums/topic/featuring-omeka-exhibits-in-wordpress

Try this:

In omeka/.htaccess you should have

RewriteBase /omeka

In omeka/admin/.htaccess you should have

RewriteBase /omeka/admin

In omeka/install/.htaccess you should have

RewriteBase /omeka/install

Note that none of these lines should have a pound sign at the beginning.


Sorry for the delay. I tried this and also tied adding another "/" -> RewriteBase /omeka/ and get the same error.

Should I be seeing the whole path "/home/pateam/public_html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php" and not just "/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php" in this error?

Are there changes to paths.php that might help?

I'm thinking of getting a new IP and starting in public_html just like normal folks.


This error may be somewhat of a red-herring. The server error log shows a FATAL PHP Error microseconds ahead of the Zend contoller error where the Omeka_Core_Resources_ Options _convertMigrationSchema($options)has not been defined. I will start a new thread on that issue if there is no previous discussion. A fresh install attempt on a new IP resulted in the same set of errors with Omeka files uploaded to the public_html directory. So the subdirectory install does not seem to be the main issue.