Your Omeka configuration file is missing (git + github + mamp)

Hmm. I bet you this has an easy answer that's eluding me.

I created an Omeka install on my work laptop (WL) and pushed it to github so I could work on it at home (HM) as well. You can find it on my account as devlib. I'm using MAMP to run my local server. Here's my .gitignore

In order to get the full install on HM I just downloaded the same version of Omeka (2.4.1) again and added the extra files and folders by hand (mv db.ini, .htaccess, etc.) I created a database with the same name, everything mostly the same. When I try to run the instance though on HM, I get "Your Omeka configuration file is missing," which seems to be coming from this bit in Db.php:

$dbFile = $this->_iniPath;

if (!file_exists($dbFile)) {
throw new Zend_Config_Exception('Your Omeka database configuration file is missing.');

My application.ini seems to have it right as

resources.db.inipath = BASE_DIR "/db.ini"

I tested with an absolute path just in case. No go.

I'm only using one branch, master, so this is not a checkout problem. I ran a diff between a working install and my git install on the same computer, everything looks pretty much the same on the top level folder, except for the name of the database.

I haven't run a diff on every single subfolder. Before committing hours to that, I wanted to make sure a) the answer was simple; b) whether Omeka is an directory contained app in the first place? c) Is this an environment variable problem?

Has anyone been able to sync the app on several local machines for group dev?

are you sure that the new db.ini and application/config.ini files are readable by the web server?

My apache group is _www. Below is the folder permissions for me and the group.

drwxr-xr-x 18 alex _www 612 Apr 12 18:26

I double checked, and _www is indeed in /etc/group.

I gave db.ini and application.ini both -rwxrwxrwx@

Heck, just to be sure I went and gave ugo ALL the permits. Resulting in this gem:

drwxrwxrwx 18 alex _www 612 Apr 12 18:26

Still no go.

(I don't know what you mean by application/config.ini. I have application/config/application.ini (Omeka 2.4.1.))

"Your Omeka configuration file is missing" (note: no "database") refers to the Omeka configuration file, which is at application/config/config.ini.

AHA! Of course! I knew I was missing something very simple. As you wrote this, Jonah Bossewith, sent me an email introducing me to the wonders of diff -aq /folder1/ /folder2/. I had found the missing config.ini file. All systems are a go now! </p>
<p>I was also looking at the wrong error message as you point out. That did not help. </p>
<p>Thanks, Patrick and John! Sorry to bother you on what turned out to be nothing but a brain fart.