Yet Another mod_rewrite Install Issue

Hello everyone,

I installed a test instance if Omeka 0.9.2 back in July of 2008 and just checked back to see the latest and decided to try out the 1.1 version.

My install page shows the "mod_rewrite is not enabled" message that many other people have apparently encountered when installing Omeka. I have read through about 20 or so forum threads, but am still not finding a solution that works for me on my FreeBSD test server with Apache 2.2.14 and PHP 5.5.12.

With out a doubt I have mod_rewrite installed and working with Apache. I know this because:

  1. My main apache config is setup for mod_rewrite
  2. A "phpinfo()" also confirms it is enabled
  3. I have other apps on the same server, like Drupal, that utilize mod_rewrite no problem
  4. I am a systems programmer/admin for a university library, so I know what I'm doing... most of the time. LOL. But like all humans I make mistakes and readily admit them. ;)

My omeka install is in a subdirectory of my Apache document root: /usr/local/www/omeka. My apache config for that directory has "AllowOverride All" set. I have tried setting the RewriteBase in different ways in the three .htaccess files:

    1. /omeka/.htaccess: RewriteBase /
    2. /omeka/install/.htaccess: RewriteBase /install/
    3. /omeka/admin/.htaccess: RewriteBase /admin/
    1. /omeka/.htaccess: RewriteBase /omeka/
    2. /omeka/install/.htaccess: RewriteBase /omeka/install/
    3. /omeka/admin/.htaccess: RewriteBase /omeka/admin/
    1. /omeka/.htaccess: RewriteBase /omeka
    2. /omeka/install/.htaccess: RewriteBase /omeka/install
    3. /omeka/admin/.htaccess: RewriteBase /omeka/admin

Still no dice. I would think the second set would be the correct way. I tried (briefly) to look for the relevant code so I could comment out the mod_rewrite check. Can I bypass this somehow? I would really love to try out version 1.1 of Omeka.

Thank you for your time.

- Gavin

I commented out line 33 of install/models/Installer/Requirements.php for now. I changed it from:




I understand I may run into problems later, but I was interested in checking out the new version. :)

- Gavin

Hi Gavin,

I'm sorry I have not responded sooner, and that you are getting those mod rewrite errors. If you are able to figure out how to correct the issue, or if you are able to narrow the problem, please keep us posted.