Yet another CSV import nightmare

When trying to upload items usins CSV import, I run into the same message

"Import settings expired. Please try again."

over and over again.
I made sure my csv file is encoded in UTF-8. I made the file with Open Office Calc from a previous matrix, then checked it using Notepad++.
I deleted the file path column, thinking this could be a probable cause.
I split the file into smaller parts (the total file contains 46 records, not at all an unreasonable amount), it still doesn't work. Even a single item can not be imported.

I tried both Mozilla Firefox and Chrome browsers with no success at all.
Import failed when using the original plugin as well as the fork by Daniel Berthereau. On one occasion, using the original plugin, the first item was successfully imported. On this occasion, the status page could be reached but was displaying erroneous information, since it stated that 0 item had been imported, and 0 rows had been skipped.

When trying import, I get to the field mapping screen, map my columns, click the Import button... then the screen goes blank. If I try to reach the status page, it is blank too.
When refreshing the page I am taken back to the 1st import screen, displaying the error message.

I turned the error log on, but the log file does not contain anything.

I am running Omeka 2.3 on a Siteground shared plan.

Omeka 2.3
PHP 5.3.29 (cgi-fcgi)
OS Linux x86_64
MySQL Server 5.5.32
MySQL Client 5.0.91

Some months ago, I succeeded in importing records with CSV import. Both the plugin and Omeka were on earlier versions, though.
I really am at a loss as to what I should do and will gladly welcome any help.

The "settings expired" errors you're seeing aren't the actual problem. They're intended to come up when you try to go back or refresh onto the setup/mapping pages of an "old" import.

The "then the screen goes blank" part indicates that there's likely a PHP-level error happening.

PHP errors don't appear in Omeka's log, they appear in the system's PHP log. You might have to ask your host for help finding or retrieving the PHP logs.

Another step to try is following the steps under "Display Error Messages" from this codex page, to attempt to show the underlying error on the white screen you're getting now.