Ye Olde Imagemagick/MAMP Path Problem

I'm having trouble finding the right directory path to ImageMagick on my instance of Omeka, running on MAMP 2.0 on OS 10.7.2. Typing "which convert" into my terminal returns this path: /opt/local/bin/convert

But no version of that path -- with or without "convert" -- passes the Imagemagick directory path test. When I try to upload a file I get "ImageMagick is not properly configured: invalid directory given for the ImageMagick command!"


For some reason people using OS X Lion have been having problems using the MacPorts version of ImageMagick.

Other users (on this thread) have had luck using the binary provided by the ImageMagick people on their site. The installation seems to be a little more involved than using MacPorts, though.

The first thing I'd try would just be rebuilding ImageMagick through MacPorts:

sudo port selfupdate
sudo port clean imagemagick
sudo port install imagemagick

Thanks, John! I was able to rebuild ImageMagick. I installed libclparser.dylib -- or at least I think I did. It's in Developer/SDKs/ MacOS10.6SDK/System/Library/Frameworks/OpenCL/Version/A/Libraries. Is that the right place for it?

Oh, and still no luck passing the directory path test.

What happens if you run

convert --version

in Terminal?

Here's what I see:

Version: ImageMagick 6.7.3-1 2011-11-08 Q16
Copyright: Copyright (C) 1999-2011 ImageMagick Studio LLC

The ImageMagick problem wasn't the only problems I've had with MAMP and Omeka - some versions worked, some didn't.. Ye Olde is exactly right. I finally switched to XAMPP ( No more problems. It's a little less flexible in that it assumes it can use Port 80 for itself but if you can put up with that it's perfectly good for testing purposes and such. I'm using XAMPP 1.7.3 with Omeka 1.4.1 and ImageMagick 6.7.2-0 (installed via MacPorts) at /opt/local/bin/ with no issues.

kintopp, at your recommendation, I switched to XAMPP, and, yup, it's working just fine with the /opt/local/bin/ path. So ... who knows? I'll stick with XAMPP from now on.

We've definitely seen plenty of problem reports for MAMP, and lately there have been several with this issue.

Judging by the reports we've had about this, it almost seems like MAMP's PHP has some configuration settings that are (at least under or in combination with Lion) not allowing paths under /opt to be used.

Using a Mac as a development environment in general can be problematic, because Omeka officially supports, and the vast majority of Omeka installations run, on Linux. There haven't been many issues with this in the past, and we do our best to make sure Omeka works the same under Mac, but it's something to think about.

The different strategies for getting everything you need on Mac all come with different annoyances. For any of them, ImageMagick has to either be installed with MacPorts or Homebrew, which requires download Xcode and many supporting libraries, or getting the binary version and manually copying files to the correct locations. For many people it may be wiser to simply use a Linux virtual machine, which would also let you take advantage of the often-superior package managers provided by Linux distros, as well as allow you to move your dev environment with you across different machines and even platforms.

I LOVE this project, and I can't wait to start using it at Queens Museum, but I have to say I kind of hate ImageMagick already... :[

I had the same frustrating issue with the path directory test failing. I've used XAMPP for years, without problems, and I can run anything I want off of it, but for whatever reason I couldn't get the directory path setting right.

I need to run this off of Windows as well. Will I just be using the regular C:\Applications\Bla\Bla\Bla... path?

Anyway, thanks @Arno Bosse!

Great project Omeka team!

Queens, NY

OK. So I got ImageMagick set up and recognized by my php installation on Windows XAMPP, but I still can't seem to set the right path inside the omeka/admin side.

Any help will be greatly appreciated.

Not sure if anyone is still interested, but I'm new to Omeka and finally figured out how to get MAMP, ImageMagick and Omeka to play nicely together on the Snow Leopard platform.

For me, it came down to the fact that Omeka thinks ImageMagick resides at /usr/local/bin, while the ImageMagick package installer actually puts the file at /opt/local/bin.

Here's the fix, available from:

Navigate to: /Applications/MAMP/Library/bin/envvars

Open envvars in TextEdit or the like and comment out these two lines:

(It's the number sign that comments them out.)

Then add this line:
export PATH="$PATH:/opt/local/bin"

Save and then open the Omeka admin dashboard in your browser.
Click on Edit General Settings and at the very bottom, set the ImageMagick Directory Path to: /opt/local/bin

For me this was all I needed!

BTW: here are the Terminal commands I used to verify my ImageMagick install had worked:

$ convert logo: logo.gif
$ identify logo.gif
$ display logo.gif

These were available a couple of screens down the page at: