What happened to my site? blank page, no error message!

I was installing Neatline plugins today, which seemed to be going just fine and then it seems like my whole site just disappeared!


When you click on the url, nothing comes up, just a blank page, no error message.

I tried refresh, different browswers, different machines.

Thanks for any help! Stacie

What was the specific plugin you were installing when the white screen occurred?

Here is the sequence of events:
I installed neatline a couple of days ago, and it worked. Today I uploaded neatline features, text, maps, waypoints, and simile. I was clicking on the install button on the site one by one for each of these, then I think it was at the point I clicked the install button for neatline text that it happened.

Even when you can't access Omeka, like the situation you're in, you can still temporarily "deactivate" plugins by just moving each plugin's folder away from their current location, either by renaming the folder or moving it out of plugins/.

Try moving away the folders for the plugin(s) you suspect caused the issue and see if that resolves your problem. Then you'll know which one is the problematic one.

Another route to try is enabling error messages. For these kinds of whitescreen errors, turning on error display doesn't always work, but it sometimes can. That would get you a name and line number for the offending file.

My hosting site said to uninstall all of the plugins, which I did, and now you can see the site, but I have no plugins for neatline. Should I reinstall one by one and see what happens?

Trying them one at a time is a good idea, yes.

Make sure you put plugins that other ones depend on, like Neatline itself, back first.

Re-enabled neatline, okay. re-enabled neatlines, map, crash!

It looks like NeatlineMaps isn't compatible with Omeka 2.

This is often the cause of an immediate error like you reported upon installing a plugin.

I hate to be a pest, but I don't know what to now. I can't get to the site and my host directory says that both neatline and maps are disabled.

Generally the easiest path forward when you've accidentally installed an incompatible plugin is to just delete the plugin folder.

NeatlineMaps is the culprit here, the one you want to delete. Neatline itself should be fine (and you'll still need it to run any of the other plugins).