WAMP install issue


New to omeka, but have successfully running joomla in a wamp environment for over a year. Every time I try to install I get this error following error:

( ! ) Fatal error: Uncaught exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Duplicate entry '1' for key 'PRIMARY'' in C:\wamp\www\digital\application\libraries\Zend\Db\Statement\Mysqli.php on line 214
( ! ) Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Duplicate entry '1' for key 'PRIMARY' in C:\wamp\www\digital\application\libraries\Zend\Db\Statement\Mysqli.php on line 214
Call Stack
# Time Memory Function Location
1 0.0008 689496 {main}( ) ..\index.php:0
2 0.0739 3624096 Zend_Application->run( ) ..\index.php:33
3 0.0739 3624096 Zend_Application_Bootstrap_Bootstrap->run( ) ..\Application.php:358
4 0.0740 3624400 Zend_Controller_Front->dispatch( ) ..\Bootstrap.php:77

Any ideas? I know omeka is not technically supported on a WAMP server but there is no harm in asking.

It looks like you need to drop or truncate or otherwise clear out your database.

That error shows that the installer is trying to add a duplicate row to a table, which means you've got old data already sitting around in the database you're trying to install to.

You can drop the tables from your database, or make a new database and point Omeka at that one, or just change the "prefix" setting in db.ini. Any of those option will make sure that there's no old tables floating around.

Thanks for the reply John. This is puzzling, as these are fresh install attempts of both Uniform Server and Omeka. The first thing I do after extracting and running Uniform Server (7.0.1 Orion) is go into phpmyadmin and create a fresh new database for omeka.



As I said, I have performed hundreds of successful installs of joomla 1.5 and 1.6 in this environment.

Will keep on plugging at it.

Update: I have tried every WAMP distro I know of, including Uniform Server, Wampserver2 and Xampp and I get the same error when trying to install under winxp or windows 7. i have tried the latest version of omeka and 1.2.1 for kicks - same problem. I may have to byte the bullet and try Ubuntu, but I am not really a linux guru. Anyone know of a good howto for linux newbs on how to build a safe and secure LAMP server with ubuntu?

Hi jjdesch,

I to have tried and failed to get Omeka working on a WAMP, MAMP or XAMMP.
I did find a tutorial on youtube http://www.youtube.com/watch?v=Y28-Yi9pWcg
The installation is on Ubuntu but is installed in virtual box. (He even does a tutorial on installing virtual box if that is the way you want to go) I have never used or even seen Ubuntu before but got Omeka up and running on my local machine using this tutorial.

Hope this helps.



I've been doing a little research on this error, and it seems to be caused by a bug in the Zend Framework that seems to cause PHP to crash when you try to execute a long SQL query (in particular, we have two queries in the installer that seem to cause this).

It's been an open bug for them for a long time. I'm not sure whether there's anything we'll really be able to do about this.

Like Kirk, I spent some hours on this installation on Windows.. with EasyPHP.

To solve this problem quite easily,
before install, you can modify manually the two following files :
- application\core\schema\elements.sql
- application\core\schema\item_types.sql

You have to shorten some descriptions of the items, then there won't be any crash anymore.