Video upload and MIME type all wonky

Okay, I have been having trouble with video uploads on Omeka. First I tried uploading the AVI file. It uploaded and the player showed on the page, but it wouldn't play.

Then, I switched the AVI to a MPEG, tried to upload it, but it kept giving me an error that it was a video/m2p2 file and wasn't supported. I read through a couple of postings and unchecked the boxes so that all files could be uploaded.

But, now the name of the file appears, but the file itself has to be clicked through before Quicktime tries to play it and then fails. It plays fine on Media Player - so I am incredibly confused.

Is there a file in the Omeka framework where I can fix this issue?

Oh, yeah - and it plays fine on Media Player on my machine - I realize it sounds like it played on Media Player via Omeka - and that would be incorrect:)

Can you tell us which version of Omeka you are using?

Is this happening on the item page or an exhibit page, or both?

And, would you mind sharing a link to a page with the video display problems?