Validator error

I recently upgraded to the latest release of Omeka. I am now unable to edit existing items or add new items through the admin panel. When I submit the changes, I get an error message:

Invalid options to validator provided

How do I correct this? Thanks!

I found the following error at the bottom of the page:

Warning: Invalid argument supplied for foreach() in /application/libraries/Zend/Validate/File/Extension.php on line 158

When you say the latest Omeka release, you mean 1.0, correct? Or do you mean the subversion trunk?



That's correct -- 1.0

OK. Could you go ahead and follow these instructions ( to receive an error log, and paste the contents in a forum message? This will help us debug the problem.


I activated the error logging per the instructions and tried to edit an existing record (which failed). When I checked the error log file, it was blank. I made sure that the file and directory permissions were set to write and that the value of error.logs in the config.ini file was set to true. Tried again and the error log was still blank.

When that didn't work, I modified the .htaccess file in the root of the installation as per the instructions (setting the value of php_value display_errors from 0 to 1). The only error messages displayed on the screen were the ones that I previously reported.

I am using Dreamhost for the site if that makes any difference.

Sorry about that. Since a warning is being displayed, it won't appear in the error log. Turning off display_errors should do the trick.

I also have a Dreamhost account, so I'll try turning display_errors on and see if I can replicate this problem.