User Activation Issue Temporary Workaround

Omeka has problem in sending out the activation email once a new user is added.
Omeka team will solve this problem in the next release.

Here is just a TEMPORARY workaround.

in file: /application/controller/UsersController.php line 122.

try {
if($user->saveForm($_POST)) {
$user->email = $_POST['email'];

so that the email attribute will get populated. But again, it is a temporary workaround.

Jackey @ GSU

Thanks for the fix, Jackey. Nice.


didn't work for me. Changed the mentioned .php but no activation email was received nor did the passwordrecovery work.

Any suggestions how I may add users?


This is one of the bugs that was fixed in the 0.9.1 release that just came out. Do me a favor and upgrade your installation to the latest version so that we can determine whether or not you are still getting this same error.

Still getting the same problem with

Maybe it is my serverconfig?


It may be possible that PHP's mail() function is disabled on your server. I'm not sure why that would be, but you could try making a test script that uses the mail() function to send a simple email to yourself. If that doesn't work, then it's your server configuration. If that does work, then I'll need some more details about what kind of server you are using with Omeka. Thanks.

I haven't got a clue how to check it and/ or how to configure the server because I am really new as serveradmin especially on Linux.

Tried to make one simple .php site for testing purposes but I got some syntaxerrors or someting.

My server is actually runnning no mailproc like sendmail or postfix. Well actually I tried to install postfix but something went wrong and I can't undo the changes/ installation.


Well, I just checked the mail() function does work, but I get no email.

So I think the mailserver isn't configured corrcect.

To be continued...


Hi KrisKelly,

meanwhile I fixed my mailserver and tested the php mail() function with success.

But still it doesn't work with Omeka.

You asked me about my server specs if the mail function is working properly, here some gerenal information:

OpenSuse 10.3
Apache 2.2.4
PHP Client API version 5.0.51a

What else do you need?

What do you think: Maybe it is caused by the bug I posted on forum topic "Unable to change password"?


Hi Martinis,

Omeka requires PHP 5.2.x or greater. It's possible that the error you're experiencing is related to this.


Hello Dave,

I am sorry for the missunderstanding: Actually I have php 5.25 installed. I just mixed it up with the API version of it.