Uploading MP3 audio files

I am trying to upload some MP3 audio files to my Omeka site but when I try to upload them I receive the message: "There was an error on the form. Please try again." Are there any suggestions or advice you can give?


Is there any more to the error message, or is that it?

Does simply retrying work? That error, by itself, on the add or edit item pages, generally shouldn't occur during normal usage.

A possible explanation I just thought of: are these particularly large MP3 files? You could you be nearing or exceeding the upload size limit (it should be listed on the form where you can upload files), which would cause this error.

Hi John,

I think the file size may the be issue here. Unfortunately, there is nothing in the error message saying so. Is there a way to increase the maximum file size for MP3 on the server?


If you're exceeding PHP's maximum limit for a POST request, there's not much Omeka can do in that situation because PHP basically silently drops the whole request. The fact that any error at all was reported is actually an improvement in Omeka 2.2.

You can increase those limits. The limit Omeka reports to you is just what it reads from the PHP settings. There are two settings you'd have to look at. The first is post_max_size, and it's what you're exceeding right now. post_max_size defines the maximum amount of data you can send in one POST, so it needs to be at least as big as the size of the file you're trying to upload, and if you're uploading multiple files at once, it needs to be bigger than all of them combined.

The second is upload_max_filesize, which is PHP's limit on the size of each uploaded file. A file must fit within both the max POST size and the upload max size for PHP to accept it.

Both of those can be set in your php.ini file. If you're just uploading single files at once, setting both to the same value, something bigger than the file you're uploading, works fine. If you want to allow multiple uploads of big files all at once, consider setting post_max_size reasonably higher than upload_max_filesize.

Thanks for the advice. Where can I find these settings?

Rescinding my previous comment - just found it. Thank you!