Uploading audio files

We would like to add some oral history audio files (mp3s)to our omeka installation, but the file size limit is too small. How can the file size limit be increased? Is there a standard file size limit you recommend for oral history audio files (interviews are usually about 1 hour long). We could break down the interviews into smaller chunks if this would be considered best practices for Omeka. Thanks for your advice.

The file size limit is generally determined by your server's PHP settings.

There are two php.ini settings that come into play: upload_max_filesize is the maximum size for any one uploaded file, and post_max_size is the maximum amount of data that can be sent to PHP (and therefore Omeka) in one go.

Both of those settings have to be set high enough to accommodate your larger files. If you're looking to upload multiple files at once, post_max_size would have to be that many times larger.

Alternatively, you can use the CsvImport plugin to import the files from URLs, or the Dropbox plugin to FTP/SFTP the files to your server and import them that way. Those plugins avoid the limitations on upload size.

Thank you! Dropbox works very well for our purposes.

Hello! I'm an Omeka.net user who's building a site that needs to access audio clips that are stored in our ContentDM site (they're oral histories that are too large to embed in Omeka itself).

From John's response above, it looks like CSV import is the way to go, but: I have no experience with setting this up and would really appreciate some help. Could a kind person out there please let me know what the steps I'd need to take would be to add audio files not as embedded files in Omeka, but as links to the files residing in ContentDM?

Thank you so much in advance for any help you can give me with this!

Oh, and I just thought I'd add: I've been following the steps for the CSV import, but it's not working. Here's what I did:

I set up an Excel file with fields Title, Creator, Date, and URL, and put my file info there.

Then, I saved as CSV, and went to Omeka's CSV Importer to import.

For the Import into Omeka, I chose the CSV file, indicated the media type (Sound, for my three mp3 sound clips), mapped title to title, creator to creator, and a date to date.

Then, I left the URL field from the CSV unmapped in Omeka, checking the "File?" box instead. Then, I clicked Import and ... 0 files imported.

Can someone please help? Was the problem that the URLs I was using ended in .mpg (they started with http:// ....)? Should I not have included the field name "URL" on my Excel/CSV documents?

It's pretty frustrating, because I'll need to make a lot of use of CSV importing, of all types of formats, and I don't know what I'm doing wrong.