Upgrading from 1.5.3 to 2.0.4 - having plugin problems

I wanted to upgrade from 1.5.3 to 2.0.4. To do this, I unzipped a fresh zip of omeka version 2.0.4 to a new folder and did all the install steps. I had a lot of plugins installed for 1.5.3 but didn't unzip the new version of the plugins to the plugins folder. I wasn't sure if I should or not. I then switched apache to point to the new version of omeka which didn't have the plugins installed. I changed the db.ini to point to the old database. When I started omeka, it asked if I wanted to upgrade the database and I did it and that seemed to work. When I went to the plugins folder, it showed a lot of pinked out plugins. I went to the sql database and removed tables for the pinked out plugins and deleted from the omeka_plugins table where rows matched the plugins. Then the pinked out plugins went away. I unzipped the new plugin to the plugins folder one at a time and as I did I would refresh the plugins page. Usually, the new plugin would appear and I could click install and it would work. For about 8 of the plugins, however, the install button would appear and I'd click install and then I get a blank page. To get back I had to again drop tables associated with the plugin and delete from the omeka_plugins table where the row matched the plugin. I would remove the plugins folder for that plugin and then the plugins page would again display without that plugin; however, I am unable to successfully install the plugin because the same thing happens each time. I can turn on error logging if needed. Did I go about this correctly or should have I unzipped all the new versions of the plugins first and maybe then it would have asked me to upgrade. I tried to go back to the older version by pointing apache to the 1.5.3 folder, but that didn't work I'm guessing because the database was upgraded for the new version of omeka and now I can't go back. If I could, I could try it over doing the upgrade a different way. What next? Our users need the plugins that aren't working.

It might be helpful to restore everything from your database backup so you can start with the plugin data being there. Then, deactivate all the plugins before you start the upgrade process.

You should also check that all the plugins you need have been updated for Omeka 2.0. Most have been, but there are a few stragglers. Plugins for Omeka 1.5.3 won't work in Omeka 2.0, so if the needs plugins aren't ready for 2.0, you'll have to wait until they are.

Once the Omeka upgrade is complete, then for each plugin you'd replace the plugin's files with the new files. Then go back to the admin plugins page, and it should signal that an upgrade is ready and prompt you to do the upgrade.

Ok, I restored from a backup and pointed my apache to the old installation of omeka and it worked. I deactivated (but didn't uninstall) all the plugins. Now, I want to go get all new zip files for the plugins I need. How do I know if the plugin will work with 2.0.4? If it is in the list of 2.0 compatible plugins can I assume it will work with 2.0.4? (http://omeka.org/blog/plugin_categories/2-0-compatible/) And if a plugin isn't in this list do I know I can't use it in 2.0.4? For instance Image Annotation. It doesn't list it as being 2.0 compatible and the minimum version is 1.3 and the target version is 1.3. I'm assuming it won't work with 2.0.4, correct? Thanks for the help. I just want to make sure I get this install right to avoid problems later.

I downloaded all the correct plugins and unzipped them, redirected apache to the new version of the software, and went to the site. I was prompted to upgrade the database and clicked to do that and got the following error:

Omeka encountered an error when upgrading your installation.

SQL error in migration: Mysqli statement execute error : Unknown column 'record_name' in 'omeka_search_texts'

Please restore from your database backup and try again. If you have any questions please refer to Omeka documentation or post a message on the Omeka forums.

In my backup I made just before attempting the upgrade there is the following:

DROP TABLE IF EXISTS omeka_search_texts;
/*!40101 SET @saved_cs_client = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE omeka_search_texts (
id int(10) unsigned NOT NULL auto_increment,
record_type varchar(30) collate utf8_unicode_ci NOT NULL,
record_id int(10) unsigned NOT NULL,
public tinyint(1) NOT NULL,
title tinytext collate utf8_unicode_ci,
text longtext collate utf8_unicode_ci NOT NULL,
UNIQUE KEY record_name (record_type,record_id),
FULLTEXT KEY text (text)

Looks like something similar happened in this thread.

Solution there was to create a new Omeka installation with the latest version, then import the backup of the old database over the new one, then do the upgrade.

I restored my database to the 1.5.3 backup and made sure the table omeka_search_texts wasn't there. If it was, I was going to drop it. I deactivated all the plugins. Then, I unzipped version 2.0.4 into a new folder and copied over my .htaccess file and my db.ini file from my 1.5.3 installation as well as the /archive folder and renamed the files subfolder to original. I copied over to the 2.0.4 install folder any extra plugins I had in the 1.5.3 install. I pointed apache to the new installation and went to the admin url. It asked me to upgrade the database and I did that and it worked. Next, I went to the plugins area of the site and I had a whole bunch of "upgrade" links there. The first two I tried took me to a blank page when I attempted the upgrade. Now what? Please help. At this point, I'm tempted to drop the table for the plugin and the row in the omeka_plugins table for that plugin and try it again, but I want to do it the right way because that strategy hasn't worked so well in the past. Thanks a million for any help!

In an attempt to get back to where I could click upgrade again, I did the following:

dropped the database and re-created it and loaded it from a backup with the plugins all deactivated.

removed everything in the plugins folder and copied everything from the plugins folder in my 1.5.3 version.

Since this also copied the delivered plugins folders for 2.0.4, I deleted the plugins folder for Coins, ExhibitBuilder and SimplePages and took these folders from a fresh unzip of 2.0.4.

Went to the admin page. It asked to upgrade the database and that worked as it should. It gave me a link to the dashboard and I went there and then to the plugins page. At that page, I'm now seeing links to upgrade Coins, ExhibitBuilder and SimplePages and links to activate or uninstall my other plugins. I know that when I click on the upgrade link I'll get a blank html page. What do you suggest?

Does anyone have any ideas?