upgraded but unable to upload Flim clips

I have upgrade the existing omeka .10 to 1.2.1 and 1.2.1 to 1.3.2. now I am unable to upload film clips of 10 MB more or less. Below mention message is showing.

"File Upload: The file 'kk.avi' could not be ingested because it has a disallowed MIME type (audio/unknown)."

when i am checking out "Disable File Upload Validation" under security setting. It is uploading but not showing with movi player.

I have load of existing data so I have to overcome the problem.
please suggest me.

The problem you're having is that your server is unable to properly detect the type of your AVI files. That mis-detection is what caused the upload problem, which you worked around by disabling file upload validation.

The same detection has to happen for Omeka to determine how to display your files. If it's unable to correctly detect the type, it will simply present a link to the file.

The component Omeka and PHP depend on for this file detection is somewhat confusingly called simply "file". Upgrading this "file" library to a more recent version often solves these kinds of problems with detection.

Another item to check is that the AVI files themselves are correct and properly formatted. Strangely-formatted or non-standard files can confuse the file-type detection.

Existing video file is supporting by the server, when I am opening that. but problem is occurring after the upgradation.

all the pdf and image file working as before. server is withe RHEL 5.2 ENT. ImageMagic is working. In old omeka database ImageMagic directory path was /usr/bin/convert and after upgradation the path is /usr/bin and also it is working.
what should I check in the server which is related with this problem in omeka database.

Now I am not upgrading another two database with new version.

Let me try to clarify:

Omeka relies entirely on mime type definitions installed on your server. These are totally separate from ImageMagick.

The particular package that provides these mime type definitions is called "file". That should also be the name of the package in yum, so running yum info file should show you what version of that package you have. There is also a command-line interface for doing basically the same MIME detection Omeka does. Run

file -bi your_movie.avi

and the output will show what your server "thinks" your AVI file is.

I have added MIME type (audio/unknown) in the setting now it is uploading without checking "Disable File Upload Validation" but have the same problem.

installed "file" version is
Name : file
Arch : i386
Version: 4.17
Release: 13
Size : 1.6 M
Repo : installed

Again I have run the commend " file -bi movi.avi" it is showing the below mentioned message "ERROR: cannot open `movi.avi' (No such file or directory)". I have run the same command with the existing video file it is showing the same result.

After running the command "file -bi 4c270dd59f79ee0945aef3114f2a3cd8.avi" (Newly generated name) it is showing the below mentioned message "video/x-msvideo"
but through the browser it is not showing with the player screen.

This is interesting.

Since running "file -bi" gives you a proper mime type (video/x-msvideo), the solution to this problem might be on the PHP side for you.

The other thing I'd look into (and that I should have suggested before) is PHP's "fileinfo" extension. Omeka recommends the use of this extension. The yum package name for the extension, is php-pecl-Fileinfo (at least on CentOS, it may likely be the same on RHEL).

I have installed php 5.2.5 (rpm)and php-pecl-Fileinfo-1.0.4-66 (rpm). which part of php have to be configured?

should I try to upgrade the database with the same existing version of omeka.