Upgrade waiting for upgrades before I can upgrade


Attempting to update from 1.3 to 1.5.1. I followed the directions in the documentation, which directed me to move db.ini and /archives, and then go to my site's admin page to access an "upgrade" script. I've attempted to do this, but all attempts to access the site result in "Public site is unavailable until the upgrade completes."

This message is all I get, even though I'm in fact 1) trying access a non-public part of the site and 2) trying to run the upgrade it says it's waiting for.

Any suggestions?

Might be a redirect not working right. Maybe try going directly to the upgrade script at {yourOmekaDomain}/upgrade

If that's not it, next step is probably to turn on error logging and check if there's anything in /application/logs/errors.log that will point us in the right direction


I had the same issue. I solved it by creating a brand new fresh install of Omeka 1.5.1, copying db.ini into it from the old one, and then going to the site, and it prompted me properly. I was upgrading from a new Dreamhost 1 click install.

This is probably just an issue of a problem unzipping or uploading the new Omeka copy, or forgetting to move some folders or files over.

The process wonderpup describes (without actually going through the install process on the new copy, which is basically pointless) is basically what the upgrade instructions are trying to tell you to do.

I am having the same problem trying to upgrade from a Dreamhost 1-click install to 1.5.3. I have tried this several times now, and made sure I followed the directions exactly. I disabled dropbox (the only plugin I have been using). I'm using the default theme.

The last time I did a clean install in a new directory. I tested the integrity of the compressed file before unzipping the archive through a shell right on the server and copying archives, db.ini and .htaccess. The only thing I haven't done is create a brand new database.

I have never seen an upgrade button, I just go straight to the error message attempting to access either the public site or the admin site. Admin takes me to /admin/upgrade. I have tried going to /upgrade and get the same message. The only difference is accessing /install -- there I get a message that omeka is installed and I may now remove the install directory.

I have turned on the error logging (as described above) and attempted to load the admin page again. No new error messages appear, and both /application/logs/processes.log.empty and /application/logs/errors.log are still blank.

The browser makes no difference either. I usually use Firefox but tried IE and 64 bit IE too.

I am using WinSCP and can clearly see that .htaccess is present. I've even tried setting the site directory to 777 temporarily to ensure that whatever needs to run could run.

I can still access the original site by renaming the directories, perhaps suggesting that the database is unchanged?

I am not a programmer, but I have looked after a few Drupal-based websites over the last 6 or 7 years, so I am not unfamiliar with the concept of upgrading. My site is nearly virgin, with a whopping total of 10 sample entries, one disabled add-on, no custom scripting, default theme. Even Drupal would be a breeze to upgrade at this state. Something seems terribly FUBAR here.

So I'm clear: when you go to the admin side of your site, you're taken to /admin/upgrade, but it still just says "Public site is unavailable until the upgrade completes?"

Yes, if I go to mysite/admin it takes me to mysite/admin/upgrade and still says "Public site is unavailable until the upgrade completes."

If I go to mysite/upgrade, it stays there but still says "Public site is unavailable until the upgrade completes."

If I go to mysite, it stays there but still says "Public site is unavailable until the upgrade completes."

If I go to mysite/install, it stays there and says "Omeka Installation

Omeka is installed. You may remove the "install" directory for security reasons." and provides two links -- one to the public pages and one to the admin pages, both of which behave as above.

BUT if I go to mysite/admin/install, it stays there and says "Public site is unavailable until the upgrade completes."

If I go to mysite/admin/themes it stays there and says "Directory access is forbidden."

but if I go to mysite/admin/plugins, or mysite/admin/applications or mysite/admin/items we are back to the old familiar "Public site is unavailable until the upgrade completes."

I was seeing the same behavior trying to upgrade from 1.3.2 to 1.5.3: going to "/admin" would get me to "/admin/upgrade", but with the "Public site is unavailable..." message.

Managed to get around the problem by restoring the admin/.htaccess file from my 1.3.2 install. That got me to the actual upgrade script and I was able to successfully upgrade.

Suspect the problem was something like this: admin/index.php bootstrap wasn't running and the admin flag wasn't getting set on the request, which borked the check on is_admin_theme in the Upgrade controller plugin. Not sure restoring the admin/.htaccess is the proper fix, but worked for me.

Hmmm. I see there is no admin/.htaccess in the 1.5.3 package. I'll try that trick. Please stand by...

<insert elevator music here>

Ahah! Now it goes to mysite/admin/upgrade with the message "Upgrade Your Omeka Database

Your Omeka database is not compatible with your current version of Omeka. Please back up your existing database and then click the button to upgrade.' " and a green button.

Stand clear, I will now push the button.

<insert more elevator music here>

Ok, now I get "Omeka has upgraded successfully." and a link to "Return to Dashboard".

<still more elevator music>

Yup, seems to work.

Perhaps, since the upgrade instructions specifically state to empty the web directory, a copy of the admin/.htaccess file should be added to the distribution package for 1.5.3.

There should be no admin/.htaccess file in recent versions of Omeka.

I think I now understand where the documentation goes awry: it tells you to keep your old .htaccess file and copy it over.

After Omeka 1.3, the admin and main htaccess files were combined into one, so the admin one isn't necessary anymore, but if you copied over your old .htaccess, that would no longer apply.

The upgrading directions tell you copy the .htaccess over only to maintain any possible customizations you may have made (like a RewriteBase setting).

If you use the 1.5.3 .htaccess, as provided in the zip package, you don't need the extra one in the "admin" directory.

I'll see if I can get the documentation cleared up on this point.

So should I restore the .htaccess file in the main directory to the original and delete the admin/.htaccess?

Thanks John, and to confirm, as you suspected I had copied over my main .htaccess file from my previous install. I've got the file from the 1.5.3 package back in place and removed the admin/.htaccess I had restored from my previous version. Upgrade is already complete, so I can't re-test that, but all else is well.