Unable to harvest (OAI-PMH Harvester)

After choosing a set to harvest from one of the repositories in the OAI-PMH Harvester demo/sample links, I am redirected back to the OAI-PMH Harvester page with a status "Queued". Clicking it, for details, I see the following repository's details:

ID 7
Set Spec 11
Set Name Case Studies
Metadata Prefix oai_dc
Base URL http://vagovernmentmatters.org/oai-pmh-repository/request
Status Queued
Initiated 2013-07-21 18:32:29
Completed [not completed]
Status Messages

And I am unable to tell what is the status of the harvest. ( I have waited more than a day )

I am using the latest plugin code from the git repository (20/7/2013)

Please help.
Nadav :-)

ditto here. anyone have a solution?

Now, I have it working. I am not sure what it was but I solved it, eventually.

I think I was missing some php xml library.
Look at Apache's error.log file. As far as I remember, the answer was there.

Hello good evening,
When I try to harvest http://eprints.rclis.org/cgi/oai2 server; Omeka returns me the following error:

Error: No entry is registered for key 'view' (date).

I tested with other repositories and get the same result.

It's a problem that you have encountered before?

Thanking you in advance for your help by sending me a cordial greeting dismissal.

Hello Vinz3g,
When you try to harvest from that repository you get

Error: No entry is registered for key 'view' (date).

because it's formatted using mods Omeka uses oai_dc.
The other repositories might be using Mods as well.

I have used this plugin, but when I made your upgrade to version 2, the harvesting don't work. I tried several data providers, but no success. The message showed by harvester is Error or In Progress (but don't finish).

This plugin have any bug?

About system:
Omeka 2.1.2
PHP 5.3.10-1ubuntu3.8 (apache2handler)
OS Linux 3.5.0-34-generic x86_64
MySQL Server 5.5.32
MySQL Client 5.5.32
Apache Apache/2.2.22 (Ubuntu)
OaiPmhRepository 2.0
OaipmhHarvester 2.0