Unable to change password

Hi again,

when editing the only existing user with super status and trying to change the password the message something like "password successfully changed" appears.

When trying to relogin the old password is still active.

How may I fix this issue?

Another problem is, while trying to click on "current password" nothing happens.


Could you upgrade your Omeka installation to version 0.9.1 (just released yesterday), and then tell me if you still get this same error? Thanks.

Will check it out on tuesday.

Still having the same problem with

It is not possible to make the new password active.

Btw. if I remember it right I was able to change the password one time right at the beginning. When installing I told Omeka the name of the superuser and a short password "test". When I entered the page I changed the password for this superuser to the correct password. It worked properly but only this one time, I think.

I've duplicated this error on my server, so I'll put up a note to fix it for our next release. If I can figure out a quick workaround before then, I'll post it here. Thanks for catching this bug.

No problem, with pleasure.

I have had similar problems with

Omeka seems to allow complex passwords, but does not seem to accept simple ones. But I get no error message to indicate that there was an error.

We noticed this as well. Is there a limit to the number of characters? Once we made it longer and a touch more complex it kept the password. Short passwords, while you get a "YOUR PASSWORD IS SAVED" in green on the page, it doesn't actually work. Maybe a note that says "YOUR PASSWORD IS TOO SHORT" or "YOU PASSWORD IS TOO SIMPLE TRY AGAIN" would be better to have.

Hi everyone,

You are right, the system should tell you that your password is too short. We added that to our list of bug fixes. Passwords should be between 6 and 40 characters, and we will add that to the Codex.

Thanks for pointing this out and sorry for the difficulty.