Trouble with Docs Viewer (

I can't seem to get PDFs to display. Here are some details:
- IE 8 (not by choice)
- Using with the Docs viewer installed. Items load properly when I uncheck the 'embed viewer in pages' in the Docs Viewer config.
- no error actually displays, when I click the item with the attached PDF, the page just hangs without getting the image
- I have not tried other file types

I really want this to work as I think Omeka would be a good choice for a pretty big project. This is just the beta test right now.

Would you mind making one of those items public that has a PDF and then post a link here?

Sure: and

It works beautifully on my Firefox at home, so maybe something to do with IE8? Unfortunately, our organization is kind of, um, strict about that. So I would really need it to work within the organization.

Hmm, there are probably factors here that we cannot control that relate to the Google Docs Viewer itself and not the plugin, necessarily.

I viewed the item PDF in IE9 and used the developers' tools to let me to browse in IE8 mode.

It loads fine in Chrome but I'm actually having trouble in Firefox getting the PDF to display.

Would you mind trying other allowable file types and see if it is just a PDF problem with the viewer?

I've just added a jpg ( and it seems to work fine in IE8.

I am focusing only on this today and will try anything I can think of here (adding other types, saving them via google docs, any other save settings on the original pdfs, browser settings, etc)

my email and phone number if it is easier to reach me off forum . . mwise [at] mfah [dot] org 713 - 353 - 1545

I seem to have solved it by adding "" as a site under options->privacy->sites. Now weighing how to explain to users, will see how widespread confusion is when I test this internally. Thanks so much for your help. I'm sure you'll hear more from me as we get this going! You can find more about the project here:

Good, I'm glad you figured out it all out. I was hunting around on Google forums and it seemed like that could be an issue.