tinyMCE Removing JavaScript

I'm having a problem configuring tinyMCE to accept JavaScript in Exhibit Builder. I tried adding extended_valid_elements:"script[language|type|src]" under the initParams in the globals.js file, but that didn't seem to work. Any help would be appreciated.

Omeka v.2.1.1
Exhibit Builder v.2.1

Thank you,

Are you sure that your scripts are being removed by TinyMCE and not by Omeka's HTML filtering (enabled under Settings > Security)?

I'll include a halfhearted recommendation here that you not include JavaScript in the user-edited text of an Exhibit: there's a reason there are several layers at which scripts could be removed.

Thank you...HTML filtering is exactly what I overlooked. Do you know of a way to safely not filter JavaScript when creating page content in ExhibitBuilder?

I don't know of any way to effectively allow "safe" inline JavaScript.

If possible, I'd consider including the script into your theme, and just having class names or something similar in your user-content markup.

Thanks, John!