Thumbnails Stopped Appearing.


Thumbnail images stopped appearing out of the blue.

I've upgraded to Omeka 2.4 and tried to run Derivative Images to fix the problems. I've also checked and my ImageMagick path is working. Nothing helps.

When I run Derivative Images I get a PHP error.

Here's the exact error:

2016-05-14T17:29:50-04:00 ERR (3): exception 'RuntimeException' with message 'The configured PHP path () is invalid.' in /hermes/bosnaweb04a/b1752/ipg.sheilalimingcom/ewl/application/libraries/Omeka/Job/Process/Dispatcher.php:114
Stack trace:

I've tried changing my PhP path on the config.ini file and that didn't fix the problem.

Can anyone help me? Everything else is working great on the site except I need thumbnails.

For reference, here's my site:

If you go to the second or third page you can see that thumbnails used to work and the stopped with no apparent rhyme or reason.

Any help would be very much appreciated. Thanks in advance for your time!



What version of PHP do you have installed? Omeka 2.4 newly requires a minimum of PHP 5.3.2.

Thank you for your quick response.

I've upgraded my PHP to 5.6 No matter what I do, I still get the same error.

But, if I switch to the GD strategy I no longer get the PHP error, but I still don't get thumbnails.

So it seems like something is wrong with my PHP but I'm not sure what or how to fix it.

It looks like you're mostly trying to make thumbnails of PDFs? GD really only works on "normal" images like JPEG, GIF, etc.

If you turn off the GD strategy, what happens when you press the "Test" button under Settings for the path to ImageMagick? Your server may have simply moved (or removed) ImageMagick, so the path might be wrong.

the Imagemagick path test says:

The ImageMagick directory path works.

I've also run an ImageMagic Test script which tells me that my server is running ImageMagick 6.6.9-7

Thank you.

Do you have error logging turned on? You should be getting an entry in your Omeka log whenever ImageMagick can't create a thumbnail. The log message may help narrow down the problem.

I do.

Here's my error.

2016-05-16T20:27:10+00:00 WARN (4): Error output from ImageMagick:

libgomp: Thread creation failed: Resource temporarily unavailable

2016-05-16T20:27:10+00:00 ERR (3): ImageMagick failed with status code 1.

Judging from this post on the ImageMagick forums, it seems that this may be some issue with quotas or limits set by your host.

You may want to contact them and tell them you're getting this error. They should be able to provide some sort of help either with allowing ImageMagick's threading to work, or with disabling the threading.

Thanks! I will.

You don't think it's related to my PHP issues?

I really appreciate it, John.