Thumbnail not loading


I am a novice developer implementing an instance of Omeka for an archive. We are running Omeka 1.0. I am able to access the admin panel and files through SFTP.

I have been able to load items and create collections and exhibits with no problems until just recently. When I add items now I only see the filename, such as '029.jpg'. Clicking on that link shows the file in a new window okay, but there are no thumbnails.

Files were showing up in archive/thumbnails and archive/files and I couldn't figure it out. Now they are not even showing up in those archive directories. Here is a link to one of my exhibits which may show my problem:

And I have tried loading images using these ImageMagick paths, to no avail:

Any help would be much appreciated.

Where exactly do you only see '029.jpg'?

The exhibit you link to is empty, which often happens when trying to view an exhibit with non-public items. The items won't appear in the public exhibit unless they, too, are public. Can you confirm the items in your exhibit are public?

Your archive does have items with images in it, so at some point you were able to do this. If you haven't changed anything in the Omeka core, the only other explanation I can think of is something on your server has changed.

If you can log on through a shell, use the 'which convert' command to find out what your path to ImageMagick is, and use that in your settings.

Sorry about the development link.

All items are indeed set to public.

I am seeing the file name 029.jpg (and not the image) on the Collections page in the div id="itemfiles" section of the div id="secondary" area; and also on all areas of the Exhibits page. All images have loaded correctly in the 'Recently Added Items' area of the Home page, however.

After speaking with our Systems Administrator he thinks there may be a configuration problem with the emiglio theme:

"there are a lot of references to /(our server)/htdocs/omeka/themes which may indicate a theme configuration problem; it should be /(our server)/htdocs/omeka/iuarchives/themes"

If this is the case do you recommend any particular action?

Also, the sysadmin says my path to ImageMagick is /usr/bin/convert, and the path to convert settings show that if this is the case I should have /usr/bin/ as my setting. Is this still right?

From looking at the other sections of your site and the fact that the links (like 029.jpg) work, it seems pretty clear that Omeka is correctly generating derivative images (thumbnails, square thumbnails, and fullsize images), so your ImageMagick settings should be fine.

It does seem like this may be an issue with your theme, since it appears to be able to correctly show the images in the "Recently Added Items" section of the main page, but not on the item/show or exhibit pages.

Does switching your theme to some other, unmodified one help at all?

Finally, you appear to be using Omeka 1.0, while the current version is Omeka 1.3.2. I'm not sure that has anything to do with this particular issue, but it does make it more difficult to troubleshoot.

I changed my theme back to the default 'Thanks, Roy' theme and then to 'Minimalist.' I uploaded a new image and Omeka generated all necessary derivative images but I still only see the file name 'Chrysanthemum.jpg' in the exhibits and items/show pages.

I am lobbying our director for an upgrade to 1.3.2, and maybe that will help.

In case that doesn't go through is there anything else I can do?

Would it be possible to copy and paste some of the code from your items/show page here?

In particular it would be useful if you could post what appears directly below the Files header, i.e. <h3>Files</h3>.

How timely. I've just run into this error this morning. Using 1.3.2. I'll do some digging and send details as soon as I can.

I have upgraded to 1.3.2 and the problem has been solved; I am now able to upload images correctly.

I am looking forward to seeing what Hope has come across regarding her error on the new version, just in case I come across this bug again.