"This is not a valid plugin" when installing Neatline 2.1.1

Hello there.

I'm new to Omeka, so perhaps I'm missing something simple here.

Just installed Omeka 2.1.1 (Dreamhost server). Went to install Neatline 2.1.1 as well as Neatline Timeline according to the instructions on Neatline.org (http://docs.neatline.org/installing-neatline.html). Dropped the unzipped folder into plugins on the server.

When I go to the plugins section on the Omeka admin panel, I see a pink box around Neatline and the error message "This is not a valid plugin." Same thing for Neatline Time.

I tried deleting and re-uploading, but it did not make a difference.

What am I doing wrong? Thanks!

Make sure the permissions are right on the Neatline plugin folders you added.

They should be the same as the other plugins in the plugins folder: readable by the server.

Hey trmartin,

Just following on what John said - maybe also just check the contents of the plugin directories to make sure nothing went awry while unzipping / deploying the plugins.

In the Neatline directory, do you see files called plugin.php and NeatlinePlugin.php?


John, David, thanks for the replies. I checked the permissions, which were fine as-is, but I tried changing them around a bit just in case. Unfortunately, I still get the error message. I did notice that I couldn't set the permission to writeable. (I can check the box, but it doesn't save - it's unchecked when I return to the settings even after it's been applied.)

I do see both plugin.php and NeatlinePlugin.php.

Thanks for any other ideas you might have.


Hey Tamar,

Is this only happening with the Neatline plugins, or for all plugins? Eg, are you able to install the plugins that ship with Omeka (Simple Pages, Exhibit Builder, etc)?


Hi David,

Yes, it's only happening with the Neatline ones (which are the only plugins I've tried so far, apart from those that ship with Omeka, all three of which work fine).

Thanks again,