There was an error on the form. Please try again.

I have re-installed omeka twice and I still receive this error. My problem involves adding items. No matter what fields I leave blank or fill in, after I hit "Save Changes" I get notified that "There was an error on the form. Please try again." I have searched and searched and I can't find any documentation on this nor anything in the forums. I work with websites a lot and I just can't figure this one out!


Sounds like that is not hitting a major error in the PHP code, but something is just going wrong in how it is processed.

My first guess is that maybe there's some javascript that isn't loaded right by the time you submit data. If you have a lot of plugins active, that could add a lot of JS that might not be ready yet on the item submit form, depending on how quickly the form is submitted. So the guess there is, if lots of plugins are active, try deactivating some of those and see if things behave better. Then, if a plugin is the culprit, we could work on making it work better.

Thanks for the quick reply Patrick.

The only plugin I had installed was the Docs Viewer an then yesterday I installed the dropbox plugin just in case it was an issue of my image files being too large. I've now uninstalled both (just using the omeka interface, I didn't remove the files from the server). Still the same notification.

Are you doing something like uploading a file when you get this error, or does it happen even for a totally blank item with nothing at all filled in or attached?

Does the same problem happen if you use a different browser?

It happens no matter how few fields I fill. I just tried putting just a title and got the same message. I usually use Safari (7.1) but just tried it in Chrome (Version 39.0.2171.71 (64-bit)). Same thing happened.

hey! so i just upgraded Omeka, and noticed there was not a file called .user.ini in the new upgrade. So i deleted the .user.ini file (i had re-uploaded it because i thought it had a similar function to the db.ini file)... and i finally got a record to upload!!