Tag Bandit


Can anyone explain how the Tag Bandit plugin works? I have downloaded it and have attempted to add tags to items resulting from a search of the database. But, it does not seem as though the tags are being associated with the selected item records. Any ideas on what I am missing? Is this a new plugin?

Thank you!

It is a new plugin, but it should work. I just tested adding and removing tags with it Omeka 1.1, and it seems to work for me.

What version of Omeka are you using? How are you trying to add the tags?

In my case, I went to the admin browse items page (which is also the page displayed for admin search results), and added the tags to the text box underneath "Add Or Remove Tags To These Items". Then I clicked the "Add Tags" button.

Let me know if this helps.


I am using version 1.1.

I did a keyword search within the administrative module to select a group of records. I input a tag and clicked on "Add tags." The system generate this message: "We started adding tags to the items you selected." But, when I search for that tag within the advanced search, I get 0 results. Is there something more that I need to do to select the records?


Try editing an item that should have the tag, and see if the tag appears there. Perhaps this is a search issue.


I have tried editing some items to which the tags should have been added, but the tags are not there.


You probably don't have the PHP-CLI setting specified correctly for background processes. Does the CsvImport or OaipmhHarvester plugins work for you? They use background processes too.

Edit application/config/config.php
and make sure your the background.php.path setting points the location of your PHP-CLI executable on your server.


I had our administrator make the change to the config.php. Still no luck. I have been able to use CsvImport and OaipmhHarvester, though.

I'm not exactly sure what the problem is. Perhaps, the the background process is trying to use a plugin file it lacks permission to use. Try changing the file permissions for the plugin files, especially the folders and files inside the TagBandit/models directory. Make sure its readable and executable by the server's user.

Is anyone else experiencing trouble with the TagBandit plugin?

I'm having the same issue. First tried to use tag bandit from admin>items>browse and clicked "Add tag". Next page said "An error occurred...". I manually added PHP-CLI path to config.php as Will suggested above (I'm on Dreamhost and v1.2) and turned on error logging. Now I can get to the message "We started adding tags to the items you selected." But no new tags are on selected items or the Tag page. I think all the file permissions are correct.

As to PHP-CLI I was able to use CSVImport on another omeka site/domain but also hosted by Dreamhost. Should I turn on log.processes on the config file?

If you use Dreamhost, your PHP-CLI setting in config.php should be:

background.php.path = "/usr/local/php5/bin/php"

Yup, that's the path I used, which got me closer (see message above). But still no tags are added.