Staff Changeover-can't add items?

Well, I have access to the site, and it will let me delete and edit items, but everytime I try to add an item I get this error code:

Omeka has encountered an error
ImageMagick failed with status code 9. Error output:

Again-don't know what any of this means, and was told the file has to be under 7mb (only 3.6)

I thought I was ready to go...but I guess not.

Sorry for all of the questions-I inherited this site and was told it would be as simple as wordpress (which I have much experience with-just not on the technical side)

Thanks for any advice you can offer?

The text of the error output might help us figure out this new issue. This old issue from the forums might be similar.

Omeka has encountered an error
ImageMagick failed with status code 9. Error output:

#0 /home/flegai1/ Omeka_File_Derivative_Image_Creator->_createImage('/tmp/95c4ae593b...', '/tmp/fullsize_9...', '-background whi...')
#1 /home/flegai1/ Omeka_File_Derivative_Image_Creator->create('/tmp/95c4ae593b...', '95c4ae593bbfc0c...', 'image/jpeg')
#2 /home/flegai1/ File->createDerivatives()
#3 /home/flegai1/ Job_FileProcessUpload->perform()
#4 /home/flegai1/ Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"J...', Array)
#5 /home/flegai1/ Omeka_Job_Dispatcher_Default->send('Job_FileProcess...', Array)
#6 [internal function]: File->afterSave(Array)
#7 /home/flegai1/ call_user_func(Array, Array)
#8 /home/flegai1/ Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#9 /home/flegai1/ Omeka_Record_AbstractRecord->save()
#10 /home/flegai1/ Item->saveFiles()
#11 /home/flegai1/ Builder_Item->addFiles('Upload', 'file', Array)
#12 /home/flegai1/ insert_files_for_item(Object(Item), 'Upload', 'file', Array)
#13 /home/flegai1/ Item->_uploadFiles()
#14 [internal function]: Item->beforeSave(Array)
#15 /home/flegai1/ call_user_func(Array, Array)
#16 /home/flegai1/ Omeka_Record_AbstractRecord->runCallbacks('beforeSave', Array)
#17 /home/flegai1/ Omeka_Record_AbstractRecord->save(false)
#18 /home/flegai1/ Omeka_Controller_AbstractActionController->editAction()
#19 /home/flegai1/ ItemsController->editAction()
#20 /home/flegai1/ Zend_Controller_Action->dispatch('editAction')
#21 /home/flegai1/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#22 /home/flegai1/ Zend_Controller_Front->dispatch()
#23 /home/flegai1/ Zend_Application_Bootstrap_Bootstrap->run()
#24 /home/flegai1/ Zend_Application->run()
#25 /home/flegai1/ Omeka_Application->run()
#26 {main}

It looks like the issue on the old forum post is similar. Could the problem be that I don't have the ImageMagik Plugin installed on the site?

Does anyone have anything to offer on this? I am not able to navigate behind the scenes, but maybe my tech support can-but they leave for vacation after tomorrow. Any assistance is greatly appreciated.

I updated ImageMagick and I am still having the same issues having the same ImageMagick status code 9 error output too. Seems like a number of people are facing the same project. Any thoughts or work arounds we can be directed to?

What version of Omeka are you using (and of ImageMagick, though that's likely less important)?

ImageMagick errors shouldn't cause exceptions or error pages since several Omeka versions ago. We will still log if ImageMagick fails to work for some uploaded file, but it shouldn't be causing an error that stops the item/file from being created.

Thanks for responding, I'm running Omeka 2.4 and Imagemagick 6.9.3. I have imported around 300 items in multiple batches with dropbox since I started using Omeka... most of the time the derivative images are generated without a problem but in some instances and particularly on some larger batches about half of the photos imported do not generate derivatives. After failed imports i've gone back to individual items and tried to upload the same image as additional file -- still no derivatives... I've also tried running the derivative images plugin. No luck. Is the status code 9 error an Omeka issue or Imagemagick? Any thoughts?

Update: looks like the derivative image plugin has worked, in part, this time round.