Some plugins (SearchByMetada) are considered as not valid plugin on Omeka 2.3.1

I Upgraded Omeka from 2.2.2 to 2.3.1 (I deactivated my plugins before upgrading) and some plugins (among them SearchByMetadata 1.2, GoogleAnalytics and CreativeCommonsChooser upgraded by DanielMK to be compatible with Omeka 2) are displayed with a "This is not a valid plugin." message. Do you reproduce the problem ?

Derivative Images v2.0 is also considered as a not valid plugin by Omeka 2.3.1.

Have you tried re-installing the plugins?

No, I will try. But Derivative Images is a fresh installation and was not installed before.

In fact, the plugins could not really be re-installed since a button "Uninstall" is not displayed on the side of the plugins names. The only thing that could be done is to remove the plugin files from the Omeka 'plugins' folder.

Sorry, yes, I mean to re-pull form github or download again and re-install on the server level.

I have been unable to reproduce your problem with Search by Metadata, Google Analytics, or Derivative Images.

Well, well. I found the cause of the problem: file rights on Linux. I executed the command chmod -R 777 /var/www/omeka and everything goes fine again. Sorry for the inconvenience.

I too have this error with Omeka 2.3.1 but am searching for a solution that doesn't involve changing the permissions on the omeka directory.

jmddrake - can you specify what versions of which plugins you're having this problem with - and how exactly it's manifesting?

I have tried without success to install Google Analytics from here I tried both the master branch and the 2.0upgrade branch. Neither worked. When I extract the .zip file, my Omeka admin interface simply says "this plugin is not valid."

Are you unzipping the file on your desktop and then unloading or unzipping the file within your ftp service? There's the possibility that a hidden file isn't getting transferred. I installed the 2.0upgrade branch using git and it works.

I had been adding the .zip file to the plugins directory and extracting there. I got it to work by using the master branch at and simply renaming the folder GoogleAnalytics. I suspect that making this same change with the 2.0upgrade branch from would have worked too. Not sure why, but it worked with the other repo.

To clarify: we renamed the *extracted* directory to GoogleAnalytics.