Solr Clearing, but not Reindexing

Hello people of the forums,

I need your help. I installed Omeka and uploaded files and some plugins and everything was working just fine. Then I tried searching for a way to add facets to my searches and found out that the Solr plugin could do that. I got it working, but when i tried it out nothing showed up in my searches. I tried adding new items and adding tags to them. After that only the new files showed up when I searched.
As I understand the problem lies with Solr: it Clears the indexes, but doesn't Reindex.

Any hints/tips/help?

Thank you.

We just ran into this, did you all figure anything out? Thanks

I'm guessing you got this solved. We were having a problem where solr search results seemed to stop working after either some plugin interaction or period of time. I thought it was the bulk metadata editor. After going through everything thoroughly, we discovered that you had to be logged in to get results, when the session expired or you are bot logged in, results showed as "0". No solution yet.

No, sadly no solution yet either...

Do you get solr search results from the public page if your logged in?

I just fixed our situation. We reverted to the solar 2.1.1 plugin from the 2.2.0 version.

Thank you for your reply,

This is troubling because it says in the requirements/installation page of solr/omeka. That the minimum version of Solr should be v4.

It's probably due to some eccentricity with our particular setup. Our environment is now Ubuntu 14, Tomcat 7.0.52, Solr 4.10.3, Omeka 2.2.2, Solr plugin 2.1.1.

What we found was that the newest sold plugin (2.2.0) only allows searching if you are logged in, so accessing the page from the general public, a solr search will return 0 results, if you log in and repeat the search, you will get the results for the search. Has no one else seen this? we have replicated this issue on two different servers.

This plus re-indexing solved our issue with the solr 2.2.0 plugin