Skipped item (files) with CSV-Import


I'm trying to upload my first csv file using CSV-Import plug-in.
It works if I don't tick "Files?" in Step2. Else, all items are skipped.
I tried various spelling changes, but it still doesn't work.

I used item type = "Still image"
I also tried with a ".txt" file, using "Text" as itme type, but it still doesn't work (=Skipped files)

Any suggestion ?


File import has to pull from an online source, not from a local one. So you had a public dropbox folder, or if you placed the folder containing those files on your server, it should work.

Sorry about the confusion - I've updated the documentation to clarify.

Great, thank you for this very quick answer.

As I don't have access to the server, I suppose I'll have to use a public dropbox. But if we have copyrighted materials; it's not really desirable.

Ok. Let's hope I'll find a way to have an access to the server when I'll have to use copyrighted materials.


Oh, well, I actually understand that the Dropbox itself actually uses the Omeka server to store the images. Do I understand well ?
It would means that there is actually no other option but allowing the person who is uploading the images to access the server. Does it ?

I apologize for the confusion. I meant the service Dropbox (or another service which allows you to put files online), not the Dropbox plugin for Omeka.

No problem.

I actually tried first (before trying the plugin) with the link provided by Dropbox, but it's a https (even if it's open to every one), isn't it a problem ? Anyway it doesn't work.

Another thing I'm like to know is how the images are used ? Are they copied on your servers ? Or do they have to stay where they are on the server ?

Thank you a lot for your help !

It should copy the files to your Omeka install in order to create the derivative files (thumbnail, etc)

Thank you meberett.
I asked my admin to open me some rights to put some files on the server but I can not have a full view on what's happening on the server.
Nevertheless, it still doesn't work.
Is there a way to debug ? Is there a specific limitation on where the images should be ?
Is it ok to launch the CSV file from a remote computer ?
Sorry for so many questions.

I'm still wondering.
What can I be helped ?
Do you want me to post the same questions in another topic ?

I believe the image files need to be accessible by link - not behind any password protection. So if your admin has given you a folder but you can't just go see those files when you type the url, then that would be the problem.

I'm not sure about the question of "launch the CSV file from a remote computer" - what do you mean?

I put all of the images I'm importing in a folder within my Omeka installation: omeka_root/files/imports

This guarantees that I can access them by URL, and not just local file path. We skip this folder when moving to staging/production, and the files can be deleted once the import is complete.

Ok. I actually had the answer today, it's just what you are saying : files have to be in a folder within Omeka installation. Not anywhere on the server.

I'm having this same issue. Importing CSV files doesn't seem to work for importing images, even when importing the test files shipped with the plugin (test.csv). I've SSHed into the box to verify that it can use wget or curl to access the image URLs, but all the items are skipped. Is there a way to enable debugging for this plugin?

I am also having the same problem. if no link provided for item files, import works well though I have tried only for two items.
When adding links to the files, files are not added at all and next items are skipped.

The error log files ay as below:

2015-06-29T08:27:48+02:00 ERR (3): exception 'Omeka_Storage_Exception' with message 'Unable to store file.' in C:\xampp

Stack trace:
#0 [internal function]:

Omeka_Storage_Adapter_Filesystem->store('C:\\Users\\IIM\\Ap...', 'original/8a7b21...')
#1 C:\xampp\htdocs\omeka-

2.3\application\libraries\Omeka\Storage.php(67): call_user_func_array(Array, Array)
#2 C:\xampp\htdocs\omeka-

2.3\application\models\File.php(424): Omeka_Storage->__call('store', Array)
#3 C:\xampp\htdocs\omeka-2.3\application\models

\File.php(424): Omeka_Storage->store('C:\\Users\\IIM\\Ap...', 'original/8a7b21...')
#4 C:\xampp\htdocs\omeka-

2.3\application\models\Job\FileProcessUpload.php(23): File->storeFiles()
#5 C:\xampp\htdocs\omeka-2.3\application\libraries

\Omeka\Job\Dispatcher\Adapter\Synchronous.php(25): Job_FileProcessUpload->perform()
#6 C:\xampp\htdocs\omeka-

2.3\application\libraries\Omeka\Job\Dispatcher\Default.php(136): Omeka_Job_Dispatcher_Adapter_Synchronous->send

('{"className":"J...', Array)
#7 C:\xampp\htdocs\omeka-2.3\application\models\File.php(203): Omeka_Job_Dispatcher_Default-

>send('Job_FileProcess...', Array)
#8 [internal function]: File->afterSave(Array)
#9 C:\xampp\htdocs\omeka-2.3\application

\libraries\Omeka\Record\AbstractRecord.php(277): call_user_func(Array, Array)
#10 C:\xampp\htdocs\omeka-2.3\application

\libraries\Omeka\Record\AbstractRecord.php(550): Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#11 C:\xampp

\htdocs\omeka-2.3\application\models\Item.php(335): Omeka_Record_AbstractRecord->save()
#12 C:\xampp\htdocs\omeka-

2.3\application\models\Builder\Item.php(204): Item->saveFiles()
#13 C:\xampp\htdocs\omeka-2.3\application\libraries

\globals.php(567): Builder_Item->addFiles('Url', 'http://localhos...', Array)
#14 C:\xampp\htdocs\omeka-2.3\plugins

\CsvImport\models\CsvImport\Import.php(720): insert_files_for_item(Object(Item), 'Url', 'http://localhos...', Array)
#15 C:

\xampp\htdocs\omeka-2.3\plugins\CsvImport\models\CsvImport\Import.php(588): CsvImport_Import->_addItemFromRow(Array)
#16 C:

\xampp\htdocs\omeka-2.3\plugins\CsvImport\models\CsvImport\Import.php(336): CsvImport_Import->_importLoop(0)
#17 [internal

function]: CsvImport_Import->start()
#18 C:\xampp\htdocs\omeka-2.3\plugins\CsvImport\models\CsvImport\ImportTask.php(39):

#19 C:\xampp\htdocs\omeka-2.3\application\libraries\Omeka\Job\Dispatcher\Adapter\Synchronous.php(25):

#20 C:\xampp\htdocs\omeka-2.3\application\libraries\Omeka\Job\Dispatcher\Default.php(150):

Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"C...', Array)
#21 C:\xampp\htdocs\omeka-2.3\plugins\CsvImport

\controllers\IndexController.php(393): Omeka_Job_Dispatcher_Default->sendLongRunning('CsvImport_Impor...', Array)
#22 C:

\xampp\htdocs\omeka-2.3\plugins\CsvImport\controllers\IndexController.php(135): CsvImport_IndexController-

>_dispatchImportTask(Object(CsvImport_Import), 'start')
#23 C:\xampp\htdocs\omeka-2.3\application\libraries\Zend\Controller

\Action.php(516): CsvImport_IndexController->mapColumnsAction()
#24 C:\xampp\htdocs\omeka-2.3\application\libraries\Zend

\Controller\Dispatcher\Standard.php(308): Zend_Controller_Action->dispatch('mapColumnsActio...')
#25 C:\xampp\htdocs\omeka-

2.3\application\libraries\Zend\Controller\Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object

(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#26 C:\xampp\htdocs\omeka-2.3\application\libraries

\Zend\Application\Bootstrap\Bootstrap.php(105): Zend_Controller_Front->dispatch()
#27 C:\xampp\htdocs\omeka-2.3\application

\libraries\Zend\Application.php(382): Zend_Application_Bootstrap_Bootstrap->run()
#28 C:\xampp\htdocs\omeka-2.3\application

\libraries\Omeka\Application.php(79): Zend_Application->run()
#29 C:\xampp\htdocs\omeka-2.3\admin\index.php(28):

#30 {main}

If I understood well, your images have to be placed in a subfolder of where omeka is installed.
For example in the folder where you have "admin", "application", "themes", you can add a subfolder where you put your files.
That's the way I got rid of the problem.