Simple Vocab with Omeka 1.3

I noticed that after upgrading to 1.3 Simple Vocab still works as intended but when you go in to edit the vocab you cannot see the terms currently being used. As far as I can tell this also means adding a new term wipes out any terms previously in use. Is there an upgrade planned to fix this or something we can do on our end?

The current version of the Simple Vocab plugin is incompatible with Omeka 1.3 due to the dropped support for the Prototype JavaScript library. We're working on an upgrade that uses the jQuery library, and hope to release it by next week.

Thank you for bringing this to our attention.


I upgraded the Simple Vocab today, with the version that works with 1.3, but I got the same problem that rrunning experienced. The vocabulary terms are not visible in the edit window. I'm little puzzled on why you're still promoting this upgrade, and I only discovered this issue, afterwards.

What exactly do you mean by "The vocabulary terms are not visible in the edit window"? Do you mean the Simple Vocab edit page or the Item edit page? What behavior are you expecting? What browser are you using?

I meant the Simple Vocab edit page. The terms that were entered for the Subject element are not there. On the other hand, on the Item edit page, the terms are there for selection. Somehow, I can't edit them but can still select them in the records.

On the Simple Vocab edit page you must select the Subject element to view and edit its vocabulary terms. Have you done this? If so, and you still don't see the terms, there must be a JavaScript error. What web browser are you using? What version?

Yes, when the Subject element is selected, the window remains empty. There are no terms in it to edit. I am using FF 3.6.13. I tried also with Chrome 9.0.597.83 with the same result.

Are there JavaScript errors? I'd like to see them if possible.

In Firefox open the error console (Ctrl+Shift+J) and clear the errors. Go to/refresh the Simple Vocab edit page. Select an element that has a custom vocabulary (an element followed by an asterisk). Copy any errors/warnings that may occur.

In Chrome open the debugger (Ctrl+Shift+J) and clear the console log (bottom left-hand corner). As above, go to/refresh the page, select an element, and copy the errors/warnings.

I'm curious, does the "Click here to display a list of texts" link produce output at the bottom of the page?

Here you go. The "Click here" link does not produce any output.

Error: Event.observe is not a function
Source File:
Line: 56

Uncaught TypeError: Object function Event() { [native code] } has no method 'observe'
. (anonymous function)simple-vocab:56

Thanks, this is helpful. It appears you're still using the previous version of the Simple Vocab plugin. That version uses a JavaScript library that Omeka 1.3+ does not support. This accounts for the Event.observe error. The new version (1.3-1.1) uses a new library. Just download the plugin and upgrade to the new version.

The right files are installed and everything is ok. My apologies. I used the wrong set of files. Thanks, Jsafley.