Seeking advisor with technical problems in omeka

I am making an omeka site for a charity on a voluntary basis. I have a minimal understanding of web development and omeka is proving sticky and taking a lot of time. I am wondering if anyone could help me for a small fee for a few hours to guide me through the initial stages? Mostly relating to uploading videos that are too big and a few appearance issues. thank you

On the size of the uploaded videos, that sounds like a server setting to ask your hosting company / server admin about. Or, it might just be a matter of condensing the size of the video in an editor.

Appearance issues might lead into some CSS work, or theme hacking work. What, exactly, would you like to change?

Hello Patrick, thanks for the reply. The site is at
Overall it is just taking me a long time to set the whole thing up. The main problem at the moment is that when I go to upload a video under "add item" it tells me the size is too big. Therefore I wondered if there is a way of linking to a utube site under "items". The second problem is less important but if you look at the site there is a black line under the header and over the content and I just want to either remove that line or change the colour. I tried various CSS codes but nothing seems to work. I am presuming it is either the margin or padding on top of the content or the padding of the header? I am sure I will have many more questions but I am stuck on these at the moment.

It looks like the CSS is on header.border-width Overriding that in your theme, even with the cop-out to !important might give some directions for the black bar.

A more direct route for the videos might just be shrinking them in an editor. Otherwise, you're probably looking at talking with the hosting company/server admin about adjusting the allowed upload size.

Thank you again. I have been tryng to find the header.border-width on css but I can't find it. I will keep looking. I am a novice at all of this and have no idea what the code might be to change this.
Videos: I am a bit confused. Why would it be the server? I often upload videos to websites and I have not had a problem. I thought it was something to do with Omeka itself having a limit on size? Again I don't know how to shrink in an editor but will look. Which is why I was wondering if there are any developers who might help?

If you go the YouTube route, UCSC's YouTubeImport plugin might help.

thanks Patrick I will take a look at this

by the way it tells me The maximum file size is 32 MB.

I think our responses crossed in writing! Yeah, there are a lot of factors about file uploads, they often come down to the maximum file size that can be uploaded. Since videos get big fast, that can easily become an issue. It's usually a server setting. When you go to the Files tab when adding an item, it'll say the maximum upload size, which comes from server settings, not Omeka setting.

On the CSS to clobber the black bar, the theme can add CSS that overrides the default.

In the default theme, or, better, in a modified copy, putting this at the end of css/style.css should move closer to what you need

header {
  border-width: 0;

header {
border-width: 0;

sorry I meant to say that I used the above in the CSS Editor but it didn't work.

OK I will look into the server issue thanks

Is there not a way in which I can link a video item to YouTube?

The work from UCSC about connecting to YouTube is, to my knowledge, the best bet.

Am I following right that you are using the CSS Editor plugin along this work?

Yes I installed CSS Editor. And I put your
header {
border-width: 0;

in the CSS Editor

I will look at UCSC in about half an hour

Patrick wonderful the UCSC is working for me..thank you. Now then back to the question about the header
... there is no change with the above code.

Hello again Patrick. I'm afraid I am having problems with video importing again. Using UCSC this time with another video I get this message

Error importing video. ImageMagick is not properly configured: invalid directory given for the ImageMagick command!

The ImageMagick directory path should be set in general settings:

Thank you for the reply. I went to general settings and "test" and got this message
The ImageMagick directory path does not work.
what do I do?

oh even though I got this message, the video did upload. How odd.

I'm guessing that, while the video file itself uploaded, the thumbnail that shows when your browse around is just the default thumbnail, not a thumbnail that hints that it is a video?

Your server admin / hosting company will likely be able to confirm that ImageMagick is installed, and tell you what the correct path is.

not sure what you mean? I am just starting off with Omeka and trying to figure out how things work. There is no thumbnail at
but you can see the video.

What is ImageMagick and why would the hosting company have to do with it? I am doing this myself. Do I install image magick?

no worries! There might be a couple things at work, partly because I'm not completely familiar with how UCSC's YouTube importer works.

ImageMagick is software that's usually, but not always, installed on web servers. It does a pretty good job of converting one kind of image to another -- when Omeka creates thumbnails, that's the underlying thing we usually rely on. It's not directly part of Omeka, which is why it brings up the question about the hosting company and what they have installed. Generally, they'll have control over that installation.

A quick test might be to see what happens if you create a new Item and attach an image file. If the same error happens, then we're looking at figuring out ImageMagick settings on the server. If you see thumbnails for the item, it means figuring out something about the YouTube importer.

OK will check this out thanks

Oh dear. When I went to add an image I got a message saying "Omeka has encountered an error" so I couldn't upload an image at all.

I looked up the website of my hosting company. I have no idea what any of this means but it says the following:
We do support ImageMagick on all of our shared hosting packages. The path depends on the system you are on:

Direct Admin (old Linux):
C:\Program Files\ImageMagick\convert.exe

Linux:: /usr/bin/convert

looking at other forums I am wondering if I should replace
fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_ExternalImageMagick"
fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_ImageMagick"
under image derivatives? I have gone to the relevant place in my server but it won't allow me to make changes?

Regarding the image uploading, following the step for retrieving error messages will give more information. I'm hoping that it will just be the same ImageMagick issue.

Those paths for imagemagick look right, though it's a little weird to have both windows and linux possibilities. /usr/bin is the most common place, and Omeka usually finds that. If it turn out that you are on a Windows server, maybe try C:\Program Files\ImageMagick as the path.

But, the additional information you found in the last comment might be easier. If it won't let you edit that file, that's something that your hosting company should be able to change. (The same goes for doing the editing to turn on error messages I mentioned at the top)

The hosting company are saying the following but this path does not work:

I can confirm that imagick is installed and can be access via system calls, specifically /usr/bin/convert is available to be called.

imagick module version 3.1.2
imagick classes Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
ImageMagick version ImageMagick 6.8.8-7 Q16 x86_64 2015-01-27

It would be really useful if you provided paid support

I don't understand bluedartrackings? Do you mean Patrick?

Hello again
I got the following information from my host company

The issue here is the way it is trying to call the file, as per the error below:
[Fri Apr 1 13:25:42 2016] [error] PHP Warning: proc_open() has been disabled for security reasons in /var/www/vhosts/45/387525/webspace/httpdocs/application/libraries/Omeka/File/Derivative/Strategy/ExternalImageMagick.php on line 193

I am afraid proc_open() would not be allowed on the shared hosting, your developers would either need to look in to implementing a possible workaround, or you will have to opt for a cloud package where it will be possible to manage the server personally.

Please note that cloud is unmanaged by default.

please advise?

Fortunately, you're actually ahead of the game on this!

What you dug up earlier about changing the derivative strategy is exactly the way to get around this. That change in the config.ini is specifically designed to be a solution to this issues, which comes up with a variety of hosting companies.

That just leaves the problem you had of not being able to edit the relevant file, which sounds like a server permissions thing that they should be able to help with

thanks Patrick. Yes this is what I told them I wanted to do but the reply above is what they sent by way of a reply. I am not a techie person but wonder if I go to my omeka files under my programmes and transfer the file in again and edit it on my computer first..would this work?

OK here is the update. I used the above fix in the relevant file. I went to my ftp filezilla. I transferred the file to the server file. But it didn't work. Got the same message. I know there is a solution to this but I am losing will to live.

We'll get it figured out eventually!

So, did you go through the steps of turning on error messages? I'm hoping to find something more than 'Omeka encountered an error' in there. The results should kinda look like gibberish, but they'll ultimately be helpful.

Also, what's the hosting company? I can check around to see if we've encountered particular quirks with them.

Good luck!

I am getting very confused. how do I turn on error messages? hosting is Blacknight. Happy to give you access through a private email if u can help! I am determined to get to bottom of this but is taking time I don't have! thanks for help

That's the steps here. You'll probably want to both turn on logging, and turn on displaying error messages to help see the most info.

oh yes i was trying to do that. I think the problem is my technical skills on the hosting side are not strong enough. I tried to do this earlier but I couldn't.
I went to the .htaccess on my server and found the line but when I saved it it saved to the laptop and not in the file on the server. this is where I am becoming stuck in general I think.
Plus do I remove the # at the start and at the end of that line?

Good. The bonus here is that sometimes people can't find the .htaccess file, so you're ahead of the game there!

If it saved to the laptop but not to the server, it might just be needing to transfer the file up to the server, like I think you described with the config.ini file.

If that's accurate, you might need to check the settings in what you use for FTP transfer -- sometimes they skip files like .htaccess that begin with ".". They're sometimes called 'hidden files' or 'dot files' in the settings for different FTP programs.

Yep! Remmove the #. That comments out the line, so the line will be ignored if it is there.

I can't access .htaccess. there is a message saying
acrobat reader can't open it because either its not a supported file or it is corrupted. This happened yesterday so I reinstalled omeka 2.4 but got the same message.

Is image magick the only way to sort this image issue out? I can't seem to sort it out.

The other option is a change in the derivative strategy you were working with before. There's also the GD strategy: Omeka_File_Derivative_Strategy_GD that would go in that same config file you were working with.

That, too, depends on what's installed on the server, but worth a try.

Hi Patrick can you explain exactly what I have to do with this GD strategy? Where exactly do I change these config files? If I go to the files on the server they open up and bring me to a notepad page which, when I change, then does not seem to be the file on the server but is on my laptop. If I go to FTP to move this to the server it doesn't seem to work and the line I save doesn't seem to save as a change but goes back to the original. Could you (please) provide very precise instructions for the IT challenged person!

It's exactly the same kind of change you were looking at a few days ago, just instead of fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_ImageMagick" it would be fileDerivatives.strategy = "Omeka_File_Derivative_Strategy_GD"

The bigger problem is, indeed, the oddity of editing and/or uploading files via FTP. Most hosting companies have some kind of editing interface for files on the server. CPanel is a common system that has that kind of feature. That angle of things is probably better answered by the hosting company, since they'll know the interface that they are providing.

would you mind if i gave you access to the server? i really want to solve this!

I want to solve this, too, but direct access would be a precedent I don't think we can go with.

OK I think I will have to find someone who can help this end

Patrick the guys at the server, Blacknight, are saying it is an issue with Omeka. I wonder if you would mind....if he could talk to you directly by email I think you guys might be speaking the same language .. my email is .... I just can't sort it out?