Seasons theme exhibit css

I want to build an exhibit using the Seasons theme, but there are some css issues that I don't know how to fix. There isn't any padding or margin (not sure which) on the left side of my page. Images and text bump up against the border.


How do I fix this?


Do you still need help with this? I have the same issue (haven't gotten around to working on it yet), but yours looks like you've fixed it. If so, how did you go about doing it? I'd like to replicate what you did. If not, I'll work on figuring mine out to help you.

I did fix it with the help of Chrome browser. I simply went to the problem page, right-clicked on it to bring up the browser's context menu, and selected "Inspect element."

In the left pane that opened up at the bottom of the browser I clicked on each line of code. Clicking on each line will highlight the corresponding section on the page. When I found the code that matched the problem section, I then looked over in the right pane of the inspector. There was a line of code that said something like .75em padding. It had a check box next to it. I unchecked it, and poof, the page was fixed.

I then searched through the css file of the Seasons theme until I found the culprit code. Deleted that line, saved and uploaded it. Problem solved.

I don't find the element you refer to above. None of the padding changes I make in style.css that increase padding on the left side of exhibit text, nor in the exhibits style sheet.


Hi Colleen,

Disclaimer: This is based on my experience with Neatline Time, but it should work the same for any plugin. Also, I've been using Omeka for approximately 2 weeks. ;)

The easiest way to keep track of theme tweaks for plugins is to either hard code the CSS into the template in question (for exhibits, this would be themes/themename/exhibit-builder/exhibits/show.php) or to override the styles with a custom CSS file (stored in /themes/themename/css/).

This mitigates the possibilities of editing the wrong file or losing the customizations during an upgrade.

It looks like the class in question is "exhibit-text" as applied to a div. I found this as r b described, but in Firefox. In the code inspector, I added "style="padding-left: 100px;" to the code and it worked, so here's hoping! In the text editor of your choice, try

div.exhibit-text {
padding-left: 100px !important;

Replacing "100px" with your desired padding.

If you save these changes in a file called exhibit_fix.css in the theme's CSS folder, you would add the line

<?php queue_css_file('exhibit_fix');
echo head_css(); ?>

To the file /themes/themename/exhibit-builder/exhibits/show.php

Note, however, that this will only add padding to the exhibit text. To include all content, it may well be easier to do something like

#content {
padding-left: 100px !important;

Which will pad everything in the content area.


Thanks for pointing me to the right CSS elements! And welcome to Omeka (2 weeks!)!

I've been using and teaching Omeka for about 5 years, but this is my first time working with a site that uses the Exhibits plugin. So I'm not as familiar with Exhibit-specific elements.

I do tweak themes and plugin views quite a bit and use GitHub to help me keep track of all my changes. Been through MANY upgrades over the years.

Thanks again! I will give this a try.


Option #1 (div.exhibit-text) did work for all exhibit page text. Option #2 (#content) did not.

And I went with your child css recommendation exhibit_fix.css. That gives me a better idea how to work with a fully custom or child css in general on thanks! I am used to do full child themes and css in Wordpress.

At least my exhibit text looks better.

Hmm! Here's a new one for you, which should take care of everything in the content area (but not your help box): #content div[role="main"] {
padding-left: 100px;

That class is also present in Seasons' style.css, with margin-top set to 1.5em and no other properties.

If that doesn't work, I got nothin.

(Thanks for the welcome!)

That works nicely, thanks!