structured data

Is there a plugin or a way to add schemas to item pages in Omeka. Specifically for people and places. I imagine I could modify the item show.php file, with some conditional statements, but I think it would be better if there was some way to manipulate this from the admin side of Omeka.

We're running an older version of Omeka 1.5.1, so maybe this is something that's addressed in the current version of Omeka.


I'm running into some trouble adding structured data to my site. When I add the structured data to my code, it doesn't show up on my website. For example, I have a custom function that creates links from the people depicted field to search results for that specific name.

Here's the relevant part of the function:

$text.='<li><span itemscope="itemscope" itemtype=""><a class="browse-link" href="' . html_escape($link) . '" title="Browse ' . $value . '" itemprop="url"><span itemprop="name">' . $value . '</span></a></span></li>';
return $text;

When I view the webpage's source the vocabulary is removed from the page.

<li><span><a class="browse-link" href="/throughtime/items/browse?search=&advanced[0][element_id]=91&advanced[0][type]=contains&advanced[0][terms]=Bondurant%2C+Sidney+W.&submit_search=Search" title="Browse Bondurant, Sidney W."><span>Bondurant, Sidney W.</span></a></span></li>

Notice the itemscope and itemprops are missing. Any thoughts or suggestions as to what I could do to fix this would be greatly appreciated.


My first guess is it might be filtered. Go to adming Settings->Security and check the settings for HTML filtering, and the elements and attributes. Maybe just turning off HTML filtering there will do the trick.

That's what I was thinking as well. However when I go to my Admin site's Settings > Security page there is no HTML filtering setting that I can change.

I've also thought it might have something to do with the DOCTYPE declaration. Currently on this site when I view the page source, this is the beginning of the page:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" ""><html lang="en-US"><head>

However, I can't even figure out how to change this. Any change I make to my theme's header.php file will always show up as the DOCTYPE above.

Sorry, I'd missed that you are running Omeka 1.5. What I'd suggested is indeed a 2.x thing.

I'm not sure what might be happening with changing the DOCTYPE in the header.php file, but I'd be surprised if that were the problem with the attributes being stripped. Then again, surprises are always a possibility.

I might test things by also modifying the application/views/commons/header.php file. Maybe something funny is happening where the theme's header.php file isn't properly overriding it. that's just my best guess at figuring out what's wrong.

Thanks Patrick I'll look into the things you suggested. And if I figure it out I'll post it on this thread.
Thanks again,

I think it has something to do with the doctype , which I still can't figure out how to change. I noticed my open graph meta tags were also being stripped of relevant attributes.

In my header.php I have
<meta property="og:title" content="<?php echo item('Dublin Core', 'Title'); ?>" />

But when you view the page source the og:title property is missing:
<meta content="Aerial view of Hospital and Medical School, ca. 1938" />

In doing some investigating I came across example 16.

But like I said before I still haven't figured out how to change my doctype.

I wanted to see what other Omeka sites had for their doctypes, so I clicked on some of the Omeka showcase websites. Most of the sites used the same strict doctype that I have.

Also in going through the showcase, I noticed the following sites were not working correctly:
Journey Stories
Ars Synthetica
Our tools of learning
Catawba River Docs
Eminent Domain

And I'm pretty sure Inventing Europe is no longer using Omeka