Rewrite Engine Error

Hi, I'm trying to test out Omeka but am running into the following error when I try to run the install.
mod_rewrite is not enabled

My web server admin has ensured me that mod_rewrite IS enabled and that AllowOverride All is set.

Any ideas what could be generating this error?

See it here:

In the installer, Omeka is checking for mod_rewrite by accessing the following URL:

This URL points to a file that doesn't actually exist, but your app will think it does if mod_rewrite is enabled.

You have mod_rewrite enabled, but if you go to that link, you'll see a 404 saying that it can't find the following file:


Could you verify that that file exists in that location, and if not, where is it located? If the path is not the same as the path to your app, then something is going wrong with generating the base web path to Omeka. Let me know what you find out.

Thanks, I passed this on to our server admin. Here's his response:

The mod_rwrite.php file exists, is readable, etc.

The document root for the virtual host is


If you go to the following URL,

it outputs DISABLED which I think is OK because you are going
there directly, not via checkModRewrite.html

Do you think the error message indicates that the rewrite is going here?

This obviously won't work.

It might be if the base path got messed up somehow. You can check by opening up paths.php in the root of your application, and at the bottom of the file put this var_dump(WEB_ROOT); which should show you When you can, let me know if the value of that variable is correct.

var_dump(WEB_ROOT); outputs:
string(35) ""

Don't mean to be pushy. Just a post-weekend bump.

This sounds like the virtual host is pointing to the wrong place, but that's just my hunch.

Yeah, I'm stumped on this one, but it doesn't seem like an Omeka bug since the paths are correct.

As a hackaround, you can put a return; statement at the top of the Installer::checkModRewriteEnabled() method in the file located at install/Installer.php. That will tell it to skip verification of mod_rewrite for the install process.

You may still have problems with your Omeka install after that, but that's a toss up and seems related to your server configuration.

Let me know if that helps.

We had a problem a lot like this with a hosting service, and the solution turned out to be editing the .htaccess file to add "RewriteBase /" as a line after "RewriteEngine On".

I had the same problem installing a test instance of Omeka on my Mac, and the problem turned to be that Apache was ignoring the instructions in .htaccess. I had to set "AllowOverrides All" for the appropriate directory in the Apache config.


I was having the same problem as VFHwebdev, so after verifying that mod_rewrite is enabled I tried your edit to the root level .htaccess file.

As a result I could proceed from Begin Installation with just a link, to Welcome to Omeka (~/install) with the form asking for details.

However, clicking submit, I again encounter mod_rewrite is not enabled.

In addition, the homepage now 404's with the message

Omeka 404
"/" is not a valid URL.

Error: script 'index.php' not found in path

Marked! I will come back to check this soon!thanks a lot.:-)
[url=][color=#FBFAF1][u]simulation taux banque credit immobilier de France[/u][/color][/url][color=#FBFAF1] - Credit immobilier de France, simulation credit immobilier. Résultat mitigé pour le crédit immobilier de France.[/color][url=][color=#FBFAF1][u]simulation taux banque credit immobilier de France[/u][/color][/url]

Thanks to my good friend Seth Blank (@antifreeze on Twitter) we solved this bug with the current problems (rewrite rule failures during install, user activation after, etc.) by adding the proper RewriteBase rules to the relevant .htaccess files:

RewriteBase / in the base dir
RewriteBase /install/ in the install dir
RewriteBase /admin/ in the admin dir

I hope this helps others who run into this problem.