Recurring 'the record was not saved' error

Hi everyone,

I'm trying to use Omeka + Neatline to build something similar to the nested poetry projects David McClure has worked on, using fragments of Sappho. Essentially the idea is to begin with an image of the papyrus fragments, then zoom into the original ancient Greek, then zoom into various translations. The plan was to make everything as SVGs in Illustrator and then enter the markup in Neatline, but unfortunately I hit a snag very early on-- the "there was an error -- the record was not saved" popup--so I'm hoping someone might be able to help me. I've read a ton of posts on Github and these forums and I have no idea what's going on-- to be sure, I don't code at all, but I don't see a clear overlap between what's happening to me and other posts, aside from the fact that it seems like server configuration is a common issue in some vague sense here.

I'm running a Mac/MAMP setup of Omeka, installed using the instructions here:
Everything seemed to go smoothly, with one small exception Involving the .htaccess file. My roommate, who is much more savvy at these things, ran something in Terminal to show hidden files and still didn't see the .htaccess file and we shrugged our shoulders and moved on. Given how often the .htaccess file comes up in these forum posts I'm wondering if this could be related. I tried to copy the file an admin posted somewhere but of course my Mac said that the . domain is reserved for the system, so it's just in there as htaccess right now and doesn't seem to be doing anything.

As I began to use the program, I was able to set my own image as a background and then to begin creating items, but very quickly noticed they weren't saving. If I create a line, it saves. If I try to save an SVG or other polygon, it doesn't work. Each time I get the same error message noted above.

I've noticed from some of the other threads that it's helpful for you guys to have the text from Chrome Developer Tools. When I go to Network --> Response, all that's there is a standard "Omeka has encountered an error" page. The only seemingly erroneous thing I see is an ERR_CACHE_MISS alert. Reading about this hasn't gotten me very far at all. One person said it could be due to Adblock, etc., so I disabled that and, but it didn't seem to change things at all.

If anyone could help me, I'd be really grateful.


Update: We did a fresh install. Everything else works, and the .htaccess file, it turns out, was there from the beginning. Permissions are set to global.

And, we've pinpointed the problem! It seems like I'm only having trouble with certain vector graphics, so I'm wondering if this is a size issue. For example, for a long time I had a hard time getting anything to save at a density above 1--which seems important for this project since it'll involve a lot of zooming--especially with the SVGs I was making out of ancient Greek text. But I just got a much shorter bit of ancient Greek to save at 5.0. Would it make sense that a short poem in ancient Greek might crash the system? If so, any sense of where the brightline lies, quantity-wise?

Thanks again,