Public site vanished after upgrade -- admin site still works

I recently upgraded an omeka install from version 1.1 to 1.21, and then to the latest version, 1.53.

So far as the admin side is concerned, everything works just fine. However, for some reason I am entirely unable to access the public site.

I can put up a dummy index.php page which shows an "out of order" notice, but that's it.

I've tried re-uploading the index page, switching themes, installing and uninstalling the various plugins, and so on, but nothing seems to make a difference.

I followed the directions on the upgrade checklist, and everything worked fine (outside a few CSS flubs) in 1.21, but now that I'm in 1.53 nothing appears on the public side at all.

We're hosted on with the following systems:
Apache version 2.2.23
PHP version 5.2.17
MySQL version 5.1.66-community-log
Operating system linux

Anybody have any ideas as to what's up?

What actually happens when you try to go to the public side?

Do you get an Omeka error page, an error from your browser or the server, or just nothing?

The first thing I'd check is the .htaccess file. Under 1.5.3, you should only have one .htaccess file from the 1.5.3 zip, and that should be in the top Omeka directory (there should no longer be one in the admin directory.

In general, I'd just make sure all the files from the 1.5.3 zip got properly uploaded.

It showed absolutely nothing.

I suspect the problem was with my old index page/custom theme, which probably included outdated code. I installed from scratch and copied over all the relevant data from the old MySQL database, and it's working fine--just need to re-do the theme and we'll be good to go.

Thanks for your response, though!