Problem with uploading .pdf

I uploaded different items with one .pdf document in it each. Three went alright but with the fourth I am encountering problems. Through admin interface I can see the uploaded .pdf and it also shows up in the user interface. But without an ImageMagick picture. Clicking it brings user or admin to /items/show/[Item ID] but when clicking the document it brings user to login and logs admin out. Now I looked into the properties of the four .pdf's. Two are PDF-version 1.5 (Acrobat 6.x), one is 1.4 (Acrobat 5.x) and the one giving problems is 1.3 (Acrobat 4.x). Could it be that Omeka cannot handle PDF-version 1.3?

The thumbnailing is all down to ImageMagick and Ghostscript, the command-line tools that actually read the PDFs.

I doubt that they don't support version 1.3, but it's possible that particular PDF is esoterically or incorrectly formatted and those tools are having trouble reading it.

You might want to enable logging and check the logs to see if any problem was noted. The symptom you're describing is that even the original file didn't get loaded, though, which could indicate a problem happening even before you get to ImageMagick, like a problem uploading.

Is there a file size differential between the ones that worked and the one that didn't?

Two files about 4Mb went ok, one file about 30Mb even also went ok. Problem file is 4Mb.

I'll try to describe what happens:

Added item with (maybe incorrectly formatted) .pdf
Takes a lot of time, then browser says:

Gateway Time-out
The gateway did not receive a timely response from the upstream server or application

When I go back to edit item, I see the original .pdf file name and also see that the item saved all information except the added tags

In user interface in /items/show/[Item ID] clicking the item goes to /files/original/e86eaaac715d4beb8e0553fcf70197c2.pdf

But this file is not there, checked this in /files/original/ directory on server ...

Hi all,

Is there any solution to this problem? It is quite annoying, since many pdfs are not being correctly uploaded....



Is the pdf not uploading at all, or is it that the thumbnails are not produced? If it is the thumbnails, the next step is to find out what version of imagemagick is on your server.

Alternatively, you could try one of the other thumbnailers, like Omeka_File_Derivative_Strategy_Imagick or Omeka_File_Derivative_Strategy_GD and see if one of those works better.

Hi Patrickmj,

It is not uploading at all. I get timeout, but it has nothing to do with sizes. Maybe it has to do with being pdf 1.4... I don't even know how to track what happened. The pdfs that get succesfully uploaded get correct thumbnails... Any clue on that?

Patrickmj and others. It was an issue with DreamHost. We've changed Omeka to one of our VPSs, and now everything works fine! Thanks anyway...

Servers and hosts are always an adventure! Thanks for reporting back, so hopefully others can benefit.

On the general question of tracking what happened, the steps for Retrieving Error Messages, especially logging, is often the first step.

I never solved the initial problem as described in first post. My conclusion was that it rather has to do with PDF-versions than with filesizes. I had this problem with a few documents and worked around by manually making thumbnails with desired pixel by pixel sizes and FTP-ing them to files/fullsize, files/square_thumbnails and files/thumbnails folders. Also FTP'd the .pdf to files/orginal folder.

(All three .jpg's and .pdf with long name like c23290cc6666465c73e63cf9ef7fc4f1 ..., which I retrieved through phpMyAdmin from database.)

I also had the idea as suggested above that using another thumbnailer would solve the problem, but never tried. Just change a line in /application/config/config.ini as described here to try out ...