Problem with Thumbnails Size

Hi, I'm using Omeka 2.1.1 and I've been having problems with the thumbnails size that I don't know how to solve.

The problem is that when the thumbnail is created it only shows a part of the original image and not the full image scaled. I've tried changing thumbnail and square thumbnail sizes and different themes but that hasn't solved anything.

It happens with images shown in the Items navigation menu (both Admin and Public) and in the Item Details in the Admin view, but not in the Item details from the Public view where the image is correctly scaled.

I've made some screenshots to show what I mean:
1- This is the Item details from the public. Here the image is properly scaled

2- And this is from the Items navigation menu

Can you help me with this, please?
Thanks in advance!

To have a consistent display, the items browse page uses the square thumbnail instead of the thumbnail. If you want to use the regular, non-squared, thumbnail, follow this guide for modifying the theme, and move the items/browse.php file over to your theme's directory.

Then, find this line:

<?php echo link_to_item(item_image('square_thumbnail')); ?>

and change it to

<?php echo link_to_item(item_image('thumbnail')); ?>

Keep in mind that some other parts of the display might come out differently

Hi, thanks to your answer I've been able to solve the problem. Now the thumbnail shows the entire image but a little bit blurry, is this one of the differences you warned me about? Do you know how to solve it?

Thanks again!

Yep--that's exactly the kind of thing that can happen. I don't know of a way to reliably fix it, but hopefully someone else on the forums will have more advice.