Problem with Omeka API Import

Hello, I've been troubleshooting the omeka api import plugin for about a week on a shared server and I'm having as much trouble with it as I was when I did an initial local installation on ampps.

I emailed the web host and received the background.php.path that is needed (/usr/local/bin/php) but it still shows an error, and it won't work when I try it. I tried changing the .htaccess file in the root but I ended up creating a 500 internal server error.

Do you have any preliminary ideas or guesses as to possible reasons why the plugin isnt working that might relate to the server itself (example: imagemagick not working unless imagick php extension is installed)? I've looked at past forum posts and nothing that's been posted has helped.

Sorry, to clarify, I changed the .htaccess file to try and have an error log show up, but I ended up breaking the site somehow so I'm not willing to try that again.

The API Import wouldn't break on things like imagemagick not being installed, but to know what's really going on it'll depend on getting that logging happening. Could you paste in what you tried when you changed .htaccess? Also, you'll want to make sure that permissions on application/logs/error.log are set to allow the server to write to it.

hey patrick, it wasnt the api import that broke the site, i just messed up editing the .htaccess file (which has since been fixed).

also, my plugin problem has been fixed. not sure if this will help anyone else in the future, but my web host had to disable exec in php.ini in order to get the plugin working, so together with adding in the necessary background.php.path it now works perfectly.