Problem with installation

Hi everybody, I am trying to setup Omeka but I am having a problem. I downloaded 1.2.1 first, put the folder in my htdocs folder (I am using XAMPP) and when I load the install page and fill in my website details this is the error I get:

Fatal error: Uncaught exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Duplicate entry '1' for key 'PRIMARY'' in E:\Software\xampp\htdocs\omeka1\application\libraries\Zend\Db\Statement\Mysqli.php:214 Stack trace: #0 E:\Software\xampp\htdocs\omeka1\application\libraries\Zend\Db\Statement.php(300): Zend_Db_Statement_Mysqli->_execute(Array) #1 E:\Software\xampp\htdocs\omeka1\application\libraries\Zend\Db\Adapter\Abstract.php(468): Zend_Db_Statement->execute(Array) #2 [internal function]: Zend_Db_Adapter_Abstract->query('??-- ?-- Dumpin...', Array) #3 E:\Software\xampp\htdocs\omeka1\application\libraries\Omeka\Db.php(74): call_user_func_array(Array, Array) #4 E:\Software\xampp\htdocs\omeka1\application\libraries\Omeka\Db.php(238): Omeka_Db->__call('query', Array) #5 E:\Software\xampp\htdocs\omeka1\application\libraries\Omeka\Db.php(238): Omeka_Db->query('??-- ?-- Dumpin...', Array) #6 E:\Software\xampp\htdocs\omeka1\application\libraries\Omeka\Db.php(252): Omeka_Db->exec('??-- ?-- in E:\Software\xampp\htdocs\omeka1\application\libraries\Zend\Db\Statement\Mysqli.php on line 214

Do you have any idea what might be the reason, thanks in advance!

If this is a brand new setup, and not working with data from an existing Omeka installation, it will be better to start right off with the latest version, instead of 1.2.1.

As for the error itself, it looks like you are pointing it to a database that already has data in it. For installation, it should point to a new, completely empty database.

When I tried empty db it just crashes and the browser says "This webpage is not available".

As for the latest version - I first tried that but I get the "mod_rewrite is not enabled." error. I googled it and saw that I need to modify the httpd file xampp\apache\conf but that didn't solve it either. Then I saw on the Omeka website that I should install the earlier version first. Are you aware of any other solution to the mod_rewrite problem?

Funny thing is I actually got it running without a problem on Windows 7 but I switched to a new laptop running Windows 8 and I got all sorts of issues. Could it be an OS thing?

The message about earlier versions is only about updating from very old version -- an existing 1.1 should update to 1.2.1 before moving up to beyond that. For something new, you should start with the latest. It isn't related to the mod_rewrite error you saw.

The mod_rewrite stuff is related to Apache configurations, so a new laptop/OS version could very easily have different Apache configurations.

First thing to check is whether the .htaccess file is there. After that, it's looking in the xampp configuration to make sure that mod_rewrite is turned on.

.htaccess is there (but just in the Omeka base folder, not in install and admin) and the mod_rewrite is turned on - I did it by following these instructions:

Edit: in the htaccess file I uncommented the line RewriteBase / but it still not working.

That's the right place for .htaccess to be. I'd double check that you found all the occurrences of AllowOverride None. It's often easy to miss one.

For the RewriteBase line, also make sure you replace it with the path to your base directory for the installation.