Problem with install

I have installed Omeka 5.1 on my Bluehost server. I think the installation went OK because when I go to the website: I get an Omeka page but it is telling me that "Omeka has encountered an error." I followed the directions for displaying error messages ("open .htaccess file in root OMEKA installation and change the .php_value display_errors to 1, etc.) but the error message is still not displaying so I'm not sure what to do next.

Just a guess, but in your question you have a period before php_value display_errors 1. If that slipped into your .htaccess file, that might explain it.

If you went through the other steps, setting config.ini to log errors, do you see anything showing up in /application/logs/errors.log ?

I had it tight in the .htaccess file (no dot before the php). I did configure the applications/config/config.ini. I checked but there is no error message there.

If the .htaccess method isn't working for you, then you can try an alternate method of setting the display_errors setting:

In the "paths.php" file in the root of the Omeka site, add the following line at the top:

ini_set('display_errors', '1');

I don't know, that looks kid of scary. You mean after the comments? (/** Constants for paths and other global metadata...

It can go before or after the comment block, as long as it's not between the /** and the */. All that matters is that it's after the<?php (and not in a comment).

All that line does is the same thing as the .htaccess change should have done. Sometimes that .htaccess change doesn't work for people who are serving their PHP files a little differently.

You'd only be inserting that line to see what the error message is, and you could take it back out right after.

An error right after install like this is usually something about permissions being wrong or bad or missing data in db.ini or one of the other config files.

I rechecked this morning and there was a message in the error log:
Confirm that the information in your db.ini file is correct.
[11-Mar-2012 12:12:02] Omeka fatal error: Access denied for user 'archive7_wstein'@'localhost' (using password: YES)

I submitted a ticket to Bluehost asking about the configuration. When I set it up the instructions advised using "localhost" as the host name. I think that is the problem but I'll see what they say.

OK, Bluehost has gotten my access issues resolved and I am at the Configuration site. There is a message there that says:
"fileinfo" module not loaded

Without the fileinfo module loaded into PHP, the content type and encoding of uploaded files about cannot be read. The installer will disable file upload validation.

What do I do about that?

There's not much you can do about it yourself, except to ask BH to install that module and hope for the best. However, Omeka should still happily install and run. The only difference is that Omeka won't be able to check whether a file being uploaded is in a list of filetypes that are forbidden. In most cases, there's really no noticable difference in using Omeka.