problem with email and localization after moving servers


The site that I helped to build during my internship has been moved to a new server and a couple of things have stopped working. I have been asked for help to fix that but I thing is something related with the server configuration not with Omeka, but would like to ask you in case you can give some clues.

The main problem is that emails don't seem to work. For example, when an user try to register in My Omeka plugin ( or send an email through the SimpleContactForm plugin (, appears an error message with the heading: "Zend_Mail_Transport_Exception Unable to send mail"

The other issue is that the configuration of the language to Spanish has stopped working. The change to locale = "es" in config.ini doesn't take effect.

If would be great if somebody help me someway. Do you thing the two problems are related?

Please note, that the version of Omeka is 1.5.2. Looking forward to use the new version! Thanks for your great work.


It's possible, at least, since both the locale setting and the email settings are both in config.ini. If something is amiss there, or with Omeka reading the file, I suppose it could affect both things. Then again, I would expect that to break the site completely.

It's a long-shot, but maybe the lines somehow got commented out? Make sure that there is no semicolon at the beginning of the lines for setting locale and, further down, the default mail type, mail.transport.type

Hi Patrick,
I have checked the config.ini file and everything looks fine. The lines are not commented out.
Thanks anyway for your replay!

Patrick, I was able to fix the problems with the emails commenting out mail.transport.type = "Sendmail" and using Smtp settings instead!

If the locale setting is still there in config.ini, have you checked to see if the files are where they're supposed to be in the application/languages folder?

There should be an "" file in that folder, that's the actual compiled translations Omeka uses for Spanish.

That was the problem! The folder languages was missing. I though that the languages files in /application/libraries/Zend/Locale/Data were the ones needed.
Thanks a lot John!