Plugin Install Issue

I'm a new Omeka user still getting my sea legs. I've installed plugins before (in class, of course) but now I can't install anymore.

Specifically, I'm working with the Social Bookmarking plug-in but tried another and couldn't load it either.

I'm going to my server, uploading the file, unzipping it, and then it's not appearing when I refresh the Omeka backend. Any ideas? I do see the unzipped file in the plugin folder along with the plugins that are working correctly.

One issue may be a box that pops up when I upload the file:
It reads:

Overwrite existing files?
Then has three modes: read, write, execute; and three boxes user, group, world with permissions below. Should those all be checked or unchecked or something?

Thanks so much. This is killing me.

I'm having the same issue! Uploaded both the Neatline and the CsvImport plugins and nothing's showing on the Omeka admin pane. Folders are unzipped and present in the correct directory, and I even set permissions on Neatline to full access across the board to make sure it wasn't a permissions issue. (I didn't get a little pop-up box, though.)

I'm running Omeka 2.2 on a clean install on a CentOs 6.5 virtual machine.

I also attempted to debug by running chgrp and chown to change group and ownership to apache, same as my working pre-bundled plugins. No joy.


Maybe check that the containing plugins folder is also readable by the server, as well as checking permissions for everything inside it.

Thanks. The permissions were indeed funky in each file, so I changed them all to the same as those plugins that are working. That didn't fix the problem, though.

I'm not sure how to determine if the plugins folder is readable by the server. The other plugins in it are working, however.

Did chmod 777 on the plugins folder & still no love. Inside the folder, I've got:

drwxrwxr-x. 3 apache apache 4096 Jul 2 09:31 Coins
drwxr-xr-x. 9 apache apache 4096 Jul 21 14:51 CsvImport
drwxrwxr-x. 9 apache apache 4096 Jul 2 09:31 ExhibitBuilder
drwxrwxrwx. 14 apache apache 4096 Jul 21 12:23 Neatline
drwxrwxr-x. 8 apache apache 4096 Jul 2 09:31 SimplePages

I can see Coins, ExhibitBuilder, and SimplePages -- the bundled plugins. Nothing else is appearing on the admin page.

Those periods at the end of the permissions for each folder are a sign that SELinux is at play here.

What do you get with ls -lZ ?

So, things have moved on a little! A friendly local sysadmin reinstalled all my plugins and now they appear. He was using wget on the server as root, and I was using local download + Cyberduck ftp transfer.

I've downloaded Scripto and transferred with Cyberduck, set ownership etc, as a test. It's the only one that's not appearing now; everything else works. ls -lZ below:

drwxrwxr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 Coins
drwxr-xr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 CsvImport
drwxrwxr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 ExhibitBuilder
drwxr-xr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 Neatline
drwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 Scripto
drwxr-xr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 SimpleContactForm
drwxrwxr-x. apache apache unconfined_u:object_r:httpd_sys_content_t:s0 SimplePages

And of course, looking at that more closely reveals the problem in the permissions for Scripto.

Ran sudo chcon -R -t httpd_sys_content_t Scripto/
and that fixed it! Adam, hope this is helpful for you as well!