Plugin Install Error

I keep getting this error when trying to install the contribution 1.0-1.1 plugin:
"The following error occurred while installing the 'Contribution' plugin: 'Contribution' plugin directory does not contain a 'plugin.php' file."
The "plugin.php." file is clearly in the directory.

Sounds like the plugin wasn't installed correctly. When uploading the plugin files, keep them in the unzipped directory and place that directly in the /plugins directory.

You might want to delete it and upload the plugin again.

I am looking right at the supposedly missing plugin.php file in the Contribution directory.
I unzipped the contribution1.0-1.1 zip file into a directory named "contribution" and uploaded that "contribution" directory to the plugins folder.
That did not work.
I unzipped the zip file into a folder named contribution-1.0-1.1 and uploaded that, and got the same error message. Any help much appreciated as I did not have this problem last month when I installed some plugins.

Let me be sure you do have the right directory structure. I think the plugin is having trouble finding all of its files.

So if we are looking at the structure of your directory it should look like this:


The directory needs to be Capitalized. In addition to the plugin.php file you should also see a folder for controllers, models, views, and the plugin.ini.

Does this match what is in your installation?

I am getting exactly error message for every plugin I try to install. I definitely have the file at (for example) omeka/plugins/Geolocation/plugin.php. I have tried deleting the whole folder and re-unzipping the plugin, but still had the same problem. I'm not sure how to get a more detailed error message.

It turned out to be a permissions problem. I made the files view-able and modify-able by all, and the plugin worked.

Most plugins will be fine with just read access.

There are only a few exceptions, like the Dropbox plugin (and the documentation for those plugins will mention if they need more access).