Plugin addition breaks public/admin pages access


I installed Omeka 2.0.4 on my Mac. It runs with MAMP.

I added a couple of plugins without any problem [1], except for the following ones which cause an page access error (both admin and public pages):

- SolrSearch
- CreativeCommonsChoser
- TermsOfService
- (there might be other plugins triggering the same issue but I haven't tried them all)

The error message is:

The website encountered an error while retrieving http://localhost:8888/omeka-2.0.4/admin/index.php/items/show/id/6. It may be down for maintenance or configured incorrectly.
Error code: 500

I have to remove the plugin folder to get the situation back to normal.

Does this problem sound familiar to anyone? Any advice please?

Thank you very much,

[1] CollectionTree, CSVImport, Geolocation, SimplePages, SimpleVocab

You are using some plugins that haven't been updated for 2.0, and those are most likely causing the error. We have tagged 2.0 compatible plugins in the directory,

Chances are the Solr Search is causing a problem.

Hi Sheila,

right, I see

I didn't spot the v2.0-compatible plugins list in first place.

Any plans to make the non compatible plugins compatible on the roadmap? CreativeCommonsChoser in particular?


We are planning to update the remaining 4 or 5 plugins that the Omeka team developed. We didn't develop the Creative Commons Chooser plugin, as you can see in the heading of its page, so it is not currently on the list.

I haven't tried it, but it is possible that you can make it work with 2.0. If you have other plugins installed that are 2.0-compatible, it would be easy enough to test CCC and see if can work with 2.0.

I tried to make the CCC plugin work (I added back the folder in the plugins directory) but this gives the server error. Maybe I need to install the plugin in a fresh instance of Omeka, i.e. without having installed other plugins such as SolrSearc which caused an issue… I can try that…

Many thanks again,